Opened 8 years ago

Closed 8 years ago

#7204 closed bug (fixed)

[E-mail] preflet crashes in Outgoing menu

Reported by: diver Owned by: bga
Priority: normal Milestone: R1
Component: Preferences/Mail Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev40404, gcc4hybrid.

Thread 596 caused an exception: Segment violation
[...]
[Switching to team /boot/system/preferences/E-mail (592) thread w>E-mail (596)]
0x00104961 in _ZL30update_image_flags_recursivelyP7image_tmm ()
   from /boot/system/runtime_loader
(gdb) bt
#0  0x00104961 in _ZL30update_image_flags_recursivelyP7image_tmm () from /boot/system/runtime_loader
#1  0x001049fa in set_image_flags_recursively () from /boot/system/runtime_loader
#2  0x0010151f in load_library () from /boot/system/runtime_loader
#3  0x001041b2 in _ZL18export_load_add_onPKcm () from /boot/system/runtime_loader
#4  0x0069505b in load_add_on () from /boot/system/lib/libroot.so
#5  0x00216adf in CreateConfigView ()
#6  0x00216c2d in OutProtocolsConfigView::OutProtocolsConfigView ()
#7  0x00217d0b in ConfigWindow::_AccountSelected ()
#8  0x00219892 in ConfigWindow::MessageReceived ()
#9  0x002f2a08 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#10 0x003b63a8 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#11 0x003b1cad in BWindow::task_looper () from /boot/system/lib/libbe.so
#12 0x002f426a in BLooper::_task0_ () from /boot/system/lib/libbe.so
#13 0x00697070 in thread_entry () from /boot/system/lib/libroot.so
#14 0x7003ffec in ?? ()
(gdb)

Change History (2)

comment:1 Changed 8 years ago by diver

Can't reproduce this crash in hrev40416. Seems to be fixed.

comment:2 Changed 8 years ago by korli

Resolution: fixed
Status: newclosed

I assume Clemens has fixed it then.

Note: See TracTickets for help on using tickets.