Opened 9 years ago

Closed 9 years ago

#7226 closed bug (fixed)

build failure - r40502 onwards

Reported by: vooshy Owned by: zooey
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

the sv catalog from hrev40502 fails to build.

LinkApplicationCatalog1 /home/vooshy/haiku/haiku/generated.x86gcc2/objects/catalogs/apps/installer/sv.catalog 

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/vooshy/haiku/haiku/generated.x86gcc2/objects/linux/lib
/home/vooshy/haiku/haiku/generated.x86gcc2/objects/linux/x86/release/tools/locale/linkcatkeys "/home/vooshy/haiku/haiku/data/catalogs/apps/installer/sv.catkeys" -l sv \
-s x-vnd.Haiku-Installer -o "/home/vooshy/haiku/haiku/generated.x86gcc2/objects/catalogs/apps/installer/sv.catalog"

...failed LinkApplicationCatalog1 /home/vooshy/haiku/haiku/generated.x86gcc2/objects/catalogs/apps/installer/sv.catalog ...
...skipped <HaikuImage>haiku.image-copy-files-dummy-system/data/locale/catalogs/x-vnd.Haiku-Installer for lack of <src!apps!installer>sv.catalog...
...skipped haiku-nightly.image for lack of <HaikuImage>haiku.image-copy-files...
...failed updating 1 target(s)...
...skipped 2 target(s)...
...updated 663 target(s)...

Attachments (1)

0001-Return-on-an-empty-string-instead-of-trying-to-write.patch (1.6 KB ) - added by Blub 9 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 by Blub, 9 years ago

Has a Patch: set

comment:2 by Blub, 9 years ago

Added a patch which seems to fix the issue. The problem seems to lie in parseQuotedString in HashMapCatalog.cpp For this particular map, the function is called with an empty string, and then the line "*out = '\0'" segfaults. Patch causes the function to simply return for empty strings instead.

comment:3 by zooey, 9 years ago

Owner: changed from bonefish to zooey
Status: newassigned

comment:4 by zooey, 9 years ago

Status: assignedin-progress

comment:5 by bonefish, 9 years ago

Component: Build SystemKits/Locale Kit
Version: R1/alpha2R1/Development

comment:6 by zooey, 9 years ago

Resolution: fixed
Status: in-progressclosed

Sometimes, behind a tiny problem there's a bigger one, desperately looking for a way to get out ... actually, this caused by a problem in the build-version of BString.

Additionally, when looking for the cause, I stumbled over a couple of problems in HashMapCatalog's parseQuotedChars()

Should be fixed in hrev40527.

Note: See TracTickets for help on using tickets.