Opened 6 years ago

Closed 4 months ago

#7236 closed bug (invalid)

Query does not return any files (AUDIO)

Reported by: martinhpedersen Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: audio attributes bfs Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When copying my music collection over from an "old" harddrive to a freshly formated, I can't query for the files anymore.

I can search on the old harddrive, but on the fresh one.. i get zero files in return.

Even tested downloading a new mp3 file to the harddrive. Added attributes with ArmyKnife, no result from query. Moved the file to the "old" partition, doing the exact same query gives me the file on that drive.

Tested on multiple builds, computers and discs.

Rev. 40527 GCC4-hybrid

Attachments (1)

Attr.png (285.2 KB) - added by martinhpedersen 6 years ago.
Doing queries on "old" (left) and new (right) partitions with same content.

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by martinhpedersen

Doing queries on "old" (left) and new (right) partitions with same content.

comment:1 Changed 6 years ago by martinhpedersen

Just realised the Audio:* attr was not indexed on my new partitions. After mkindex'ing all the attrbutes I see the result I was expecting.

Shouldn't these attributes be indexed by default?

comment:2 Changed 6 years ago by anevilyak

There are arguments both for and against that ; the problem is, each additional index you add also incurs extra performance overhead for some filesystem ops, so it's not necessarily advisable to automatically add an index for every single attribute a user might ever possibly want to query for.

comment:3 Changed 6 years ago by martinhpedersen

I can understand why we don't want too many indices, but I thought audio was one of the things most people would query for. But, clearly not a bug then, so this ticket should probably be closed :)

comment:4 Changed 4 months ago by axeld

  • Resolution set to invalid
  • Status changed from new to closed

Better late than never...

Note: See TracTickets for help on using tickets.