Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#724 closed bug (fixed)

Tracker and Terminal unable to delete files with non-ascii filenames

Reported by: info@… Owned by: axeld
Priority: normal Milestone: R1
Component: System/libroot.so Version:
Keywords: Cc: diver, adeynichenko@…, siarzhuk
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Both tracker and terminal unable to delete files with non-ascii filenames.

Error produced: No file or directory

To reproduce:

To reproduce: install beos max edition (latest) on disk image (via vmware). Mount this image via Haiku. Try deleting files from the Locale directories.

Attachments (1)

lsbug.png (23.3 KB) - added by darkwyrm 13 years ago.
A screenshot of the output of ls

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by diver

Cc: diver added

Changed 13 years ago by darkwyrm

Attachment: lsbug.png added

A screenshot of the output of ls

comment:2 Changed 13 years ago by jackburton

Could this be related to #215 ?

comment:3 Changed 13 years ago by adeynichenko@…

Cc: adeynichenko@… added

comment:4 Changed 11 years ago by jackburton

Platform: All

Another way to reproduce: Grab the weekly super pack vmware image from haikuware, mount it from your own haiku image, and delete the Wonderbrush directory. Then empty the trash.

comment:5 Changed 11 years ago by axeld

Great, thanks Stefano! I can finally reproduce this problem!

comment:6 Changed 11 years ago by siarzhuk

Cc: siarzhuk added

comment:7 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

Fixed in hrev24458. No wonder I couldn't reproduce it: the problem was only triggered when using the original BFS to write to Haiku BFS volume. strcmp() and friends did not work correctly!!!

comment:8 in reply to:  7 Changed 11 years ago by jackburton

Replying to axeld:

Fixed in hrev24458. No wonder I couldn't reproduce it: the problem was only triggered when using the original BFS to write to Haiku BFS volume. strcmp() and friends did not work correctly!!!

Whoah! Good catch!

comment:9 Changed 11 years ago by axeld

Component: System/KernelSystem/libroot.so
Note: See TracTickets for help on using tickets.