Opened 9 years ago

Closed 13 months ago

#7255 closed bug (fixed)

Fetching mail from IMAP with partial mail download limit >0 KB has totally irritating status window updates

Reported by: stippi Owned by: czeidler
Priority: normal Milestone: R1
Component: Servers/mail_daemon Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I believe the problem can be observed with the partial mail download limit increased from its default 0 KB. I prefer my mails to be locally copied, I only want largish mails to be a partial download by default. So I set the setting to 200KB. When mail_daemon first fetches 1280 mails, the status window updates are totally irritating. It appears mail_daemon first downloads the headers of 250 mails at a time, then tries to obtain the size of the body for each mail to decide whether to download it. During this time, command line output can be observed for each mail, while the status window will stay without any update for a long time. I also observed that the progress bar went back to zero, and/or the status window disappearing. Later it was shown again with a weird "250/0" label. Everything was one single synchronizing operation, and the mail status should have been open the whole time with the progress smoothly increasing until the process is done.

Change History (4)

comment:1 by czeidler, 9 years ago

Resolution: fixed
Status: newclosed

Fixed in hrev40832. First the headers are downloaded. When the body is fetched the status is updated.

comment:2 by stippi, 9 years ago

Resolution: fixed
Status: closedreopened

The process has improved significantly. The progress bar fills continuously now. The problem with the weird labels is still present however. I believe it happens when you reach more than 1000 mails. With the Tracker folder open, you can see that mail_daemon downloads in batches of 250 mails (first 250 partial, then body as per the setting). When there are 1000 mails in the folder, the progress bar label switches from x/12xx to something like "x/0 mails", with x being a small number, possibly restarting at 1. It appears that it was downloading the mails 751-12xx, and the wrong label appeared after fetching the partial mails 751 to 1000. The progress bar was correct the whole time, only the label is the problem.

comment:3 by czeidler, 9 years ago

Hm can't reproduce it maybe I fixed it in the meantime... Will watch it.

comment:4 by waddlesplash, 13 months ago

Resolution: fixed
Status: reopenedclosed

Fixed now, it seems.

Note: See TracTickets for help on using tickets.