Opened 13 years ago

Closed 5 years ago

#726 closed bug (duplicate)

ICO Translator doesn't reject bad input bitmaps in Identify

Reported by: darkwyrm Owned by: 3dEyes
Priority: low Milestone: R1
Component: Add-Ons/Translators/ICO Version: R1/Development
Keywords: Cc: diver
Blocked By: #4874 Blocking:
Has a Patch: yes Platform: All

Description (last modified by marcusoverhagen)

The ICO translator, when set to enforce proper icon sizes, rejects input bitmaps with bad sizes in Translate, but not Identify. The result is that it can be chosen to translate an image, but it won't actually do the deed.

This can be reproduced by opening an image in ShowImage and dragging a selection larger than 48x48 pixels to the desktop. ShowImage spits back an error about not being able to save the bitmap clipping.

Attachments (1)

0001-ico-translator-identify.patch (1.1 KB ) - added by Freeman 6 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 by diver, 13 years ago

Cc: diver added

comment:2 by marcusoverhagen, 13 years ago

Description: modified (diff)
Owner: changed from marcusoverhagen to axeld
Platform: All

reassigning to component author

comment:3 by axeld, 10 years ago

Component: - GeneralAdd-Ons/Translators/ICO
Version: R1/Development

comment:4 by siarzhuk, 7 years ago

Owner: changed from axeld to siarzhuk
Status: newassigned

This ticket was published as GCI 2012 task. ​http://google-melange.appspot.com/gci/task/view/google/gci2012/7984205 So I take ownership of it.

by Freeman, 6 years ago

comment:5 by Freeman, 6 years ago

Has a Patch: set

comment:6 by Freeman, 6 years ago

I cant exactly reproduce what is described. What kind of image did you open to save a clip from? And how did you set to it become an ico file automatically? This patch should add reject by size functionality.

comment:7 by 3dEyes, 6 years ago

Before you run this code from the patch, you must first check the direction of the translation.

comment:8 by siarzhuk, 6 years ago

Owner: changed from siarzhuk to 3dEyes

comment:9 by pulkomandy, 5 years ago

I can't reproduce this either with ShowImage. Is there another way to trigger this?

comment:10 by puckipedia, 5 years ago

Hmm, seems to be that #4874 is a duplicate of this, same issue and it seems the solution there is what keeps this bug from happening.

comment:11 by umccullough, 5 years ago

Blocked By: 4874 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.