Opened 9 years ago

Closed 4 years ago

#7268 closed bug (fixed)

[media_addon_server] sometimes fails to fully init on boot

Reported by: adamk Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/media_addon_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I downloaded the latest nightly raw disk image a few nights ago and installed it to a flash drive in an effort to see if https://dev.haiku-os.org/ticket/3794 has been fixed yet (or if OpenSound would work again). Unfortunately, MediaPlayer was unable to play any ogg or mp3 file I tried, complaining:

There is no decoder installed to handle the file format, or the decoder has trouble with the specific version of the format.

Tried a dozen mp3 files and three ogg files. The mp3 files worked with the disk image for alpha2, so something bad has happened between now and then. I tried with hrev40596.

Attachments (1)

media_init_failed.png (39.7 KB ) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 by diver, 9 years ago

Version: R1/alpha2R1/Development

For me media_server/media_addon_server often doesn't pick up codecs, so I have to restart media server in Media preflet to fix it. Maybe this is the case for you too?

comment:2 by adamk, 9 years ago

Yes, that seems to be the case here, too. Once I restarted the Media server, I was able to play an mp3 file. I guess this bug should be updated, then, to report that the codecs aren't picked up till after the media server is restarted.

comment:3 by diver, 9 years ago

Component: - GeneralServers/media_addon_server
Owner: changed from nobody to axeld

comment:4 by diver, 9 years ago

Summary: mp3/ogg do not work on nightly raw disk images[media_addon_server] sometimes doesn't pick up media plugins

by diver, 9 years ago

Attachment: media_init_failed.png added

comment:6 by HaikuBot, 9 years ago

I have same bug since I upgrade my haiku from hrev40421 to hrev40800 (own build). Each time when I start system I going to the media preflet and restart media_addon_server. Otherwise i can't listen music or watch movies and got same as on picture above.

Last edited 9 years ago by HaikuBot (previous) (diff)

comment:7 by diver, 8 years ago

Summary: [media_addon_server] sometimes doesn't pick up media plugins[media_addon_server] sometimes fails to fully init on boot

comment:8 by Barrett, 4 years ago

Is this ticket still there? I can't replicate it in any way and i think this code was worked in the latest 4 years.

comment:9 by waddlesplash, 4 years ago

Resolution: fixed
Status: newclosed

I haven't seen this one either. Closing as fixed.

Note: See TracTickets for help on using tickets.