Opened 8 years ago

Closed 8 years ago

#7319 closed bug (fixed)

WebPositive - Automatically downloads embedded objects

Reported by: deejam Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #7190 Blocking:
Has a Patch: no Platform: All

Description

WebPositive autmatically downloads some embedded objects.

How to reproduce: Visit http://www.sundsvallfans.se/ or create the following html page:

<html>
	<body>	
		<object width="957" height="120">
			<embed src="http://www.sundsvallfans.se/global/swf/Maxiplay_957x120.swf" width="957" height="120" />
		</object>
	</body>
</html>

GCC2 Hybrid, hrev40735. WebPositive hrev573.

Change History (6)

comment:1 Changed 8 years ago by deejam

Another examle is this page that will download an embedded midi file.

comment:2 Changed 8 years ago by stargatefan

https://dev.haiku-os.org/ticket/7190

this is a dupe and I suggested closing my tickt as this ticket better illustrates the problem I observed. JIC ryan reads this one first.

comment:3 Changed 8 years ago by korli

Indeed these downloads should occur but not in the Downloads window, and in a temporary directory. Is the target directory the same than normal downloads?

comment:4 Changed 8 years ago by korli

Blocked By: 7190 added

(In #7190) Closing as a duplicate of #7319. Thanks stargatefan

comment:5 in reply to:  3 Changed 8 years ago by deejam

Replying to korli:

Is the target directory the same than normal downloads?

As far as I understand it, it is treated as a file that should be downloaded by WebPositive. Therefor it downloads as any other file using Downloads and to the same target directory. If not changed in Settings, it will download to Desktop.

comment:6 Changed 8 years ago by leavengood

Resolution: fixed
Status: newclosed

Fixed (more or less) in WebPositive r582.

Note: See TracTickets for help on using tickets.