Opened 9 years ago

Closed 9 years ago

#7373 closed bug (invalid)

Network connectivity lost when arp host address changes detected

Reported by: kallisti5 Owned by: axeld
Priority: high Milestone: R1
Component: Network & Internet/Stack Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've seen this quite a few times and decided to open a ticket to track it. gcc4 hybrid.

When there is an arp host on the network that changes it's mac address (virtual machine? network stack bug?) all network connectivity is lost until the arp host changes the mac address back.

example:

KERN: ARP host 1711150a updated with different hardware address 5c:26:0a:1a:2f:29.
KERN: ARP host 1711150a updated with different hardware address 00:50:56:76:f1:cb.
KERN: ARP host 1711150a updated with different hardware address 5c:26:0a:1a:2f:29.
  • When the second message appears... network connectivity is lost (can't ping gateway or anywhere external to my local IP)...
  • when the third message appears (a few seconds later), network connectivity is regained.

The MAC addresses and associated hosts are on the same subnet but not in direct communication. I also noted a *large* number of hosts in the arp table:

arp | wc -l
140

I know for a fact I have not spoken with 140 systems... my linux system on the same network (which connects to many more hosts) only has 3-4 entries at any given time (linux seems to drop arp hosts from the table when connections are no longer present)

I am not sure if the ARP messages the cause of the problem or are the result of another problem.

Priority at High as it blocks network connectivity and is commonly seen on my large vlan'ed work subnet with many varying systems. Feel free to reduce if deemed not a high priority issue.

Change History (1)

comment:1 by kallisti5, 9 years ago

Resolution: invalid
Status: newclosed

ack.. closing this.

Someone set a vmware host as a static IP within a DHCP address range. DHCP server assigned the IP to me thus causing an IP address collision. While Haiku could use better checking for IP collision, this isn't Haiku's fault.

Note: See TracTickets for help on using tickets.