Opened 8 years ago

Closed 7 years ago

#7397 closed enhancement (fixed)

ATI/AMD HD5770 PCIE Graphics card unsupported

Reported by: stargatefan Owned by: kallisti5
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

ATI/AMD video cards have unsupported mode setting/multidsiplay and other utlitys unsupported. Proper modesetting and under/over/scaling would be nice.Just figured I'd put this here. If any devs working on this want to send my updated build files to test. Please let me know.

Attachments (3)

syslog (280.5 KB) - added by stargatefan 8 years ago.
syslog-michaelvo (207.7 KB) - added by michaelvoliveira 8 years ago.
my syslog
radeoninfo (7.9 KB) - added by stargatefan 8 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 8 years ago by michaelvoliveira

It boots and works when I add info from my HD5550, but is not scaling at right resolution (1920x1080)

It's related with http://dev.haiku-os.org/ticket/7395

Changed 8 years ago by stargatefan

Attachment: syslog added

comment:2 Changed 8 years ago by stargatefan

Summary: ATI/AMD HD5xxx series cards are unsupportedATI/AMD HD5770 PCIE Graphics card unsupported
Type: enhancementbug

comment:3 Changed 8 years ago by stargatefan

Thanks for the hardwork, where do we send the beverages ??

Changed 8 years ago by michaelvoliveira

Attachment: syslog-michaelvo added

my syslog

comment:4 Changed 8 years ago by michaelvoliveira

For me, HD resolutions is still impossible. I can`t get a readable 1920x1080 resolution with my XFX Radeon HD 5550 yet

Changed 8 years ago by stargatefan

Attachment: radeoninfo added

comment:5 in reply to:  4 Changed 8 years ago by stargatefan

Replying to michaelvoliveira:

For me, HD resolutions is still impossible. I can`t get a readable 1920x1080 resolution with my XFX Radeon HD 5550 yet

what monitor are you using and did you rescale the the Fonts Icons etc ? Biggest thing that drive me nuts is the underscalling. arrgghh.Its horrific on a 23 inch monitor 16:9 monitor.

Totally willing to send who ever is working on this, the beverage of their choice.

Last edited 8 years ago by stargatefan (previous) (diff)

comment:6 Changed 8 years ago by michaelvoliveira

@stargatefan Hi! I'm have an LG Flatron E2240S 21,5 inches at 16:9..

comment:7 Changed 8 years ago by anevilyak

Owner: changed from nobody to kallisti5
Status: newassigned
Type: bugenhancement
Version: R1/alpha2R1/Development

comment:8 Changed 8 years ago by kallisti5

validated PCIID for 5770 (0x68b8) is already in radeon_hd driver.

comment:9 in reply to:  8 Changed 8 years ago by stargatefan

Replying to kallisti5:

validated PCIID for 5770 (0x68b8) is already in radeon_hd driver.

highest reported resolution in screen preflet haiku rev 41516 is 1280x1024 with a 15% underscaled output on the monitor. IE there is a large black boarder roughly 1.5 nchs on each side of the screen and .75 inchs top and bottom. I noticed in the log file that the edid reported a 1920/1080 resolution being avaialable. What would it take to enable this mode ?

comment:10 Changed 8 years ago by michaelvoliveira

I got this large black boarder at bottom when I set 1280x720....

comment:11 Changed 8 years ago by kallisti5

This is expected behavior.. the VESA driver can't set non-standard modes, and my radeon_hd driver is still in progress.

Please be patient, I am working as fast as I can :)

comment:12 Changed 8 years ago by stargatefan

I will test whatever you like since I can now build again.

comment:13 Changed 7 years ago by kallisti5

Try the current Haiku nightlies, radeon_hd support is pretty stable now.

Thanks!

comment:14 Changed 7 years ago by kallisti5

try post hrev43810. hrev43810 fixes a *big* oops.

comment:15 Changed 7 years ago by kallisti5

Resolution: fixed
Status: assignedclosed

Analog is verified working, digital output works *sometimes* and has some known bugs (which i'm working through)

If you still have issues, please do a search and open a new ticket if it isn't a known issue.

Note: See TracTickets for help on using tickets.