Opened 9 years ago

Closed 8 years ago

#7439 closed enhancement (fixed)

[patch] OptionalPackages - Caya

Reported by: Barrett Owned by: mmadia
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: optional, package, caya, Cc: pulkomandy
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

I have created an updated package of Caya and the patch to add it as optional package. I have followed the doc on haiku-os.org anyway if there is any error / problem..let me know : )

Attachments (4)

OptionalPackage-Caya-prealpha.patch (1.0 KB ) - added by Barrett 9 years ago.
add caya as optional package
caya-haikuports.diff (2.4 KB ) - added by Barrett 9 years ago.
patch to build caya with haikuporter
caya-haikuports.2.diff (1.2 KB ) - added by Barrett 8 years ago.
Patch fixing the problems with caya's bep file
CayaOptionalPackages.diff (1.3 KB ) - added by scottmc 8 years ago.
patch to add caya as an optional package

Download all attachments as: .zip

Change History (32)

comment:1 by Barrett, 9 years ago

Has a Patch: set

comment:3 by bonefish, 9 years ago

Owner: changed from bonefish to nobody
Status: newassigned

BTW, the packages are in lexicographical order in OptionalPackages.

by Barrett, 9 years ago

add caya as optional package

comment:4 by scottmc, 9 years ago

Owner: changed from nobody to scottmc
Version: R1/alpha2R1/Development

Barrett, Can you put together a working .bep file so that Haikuporter can automatically build this? Put it in haikuports/haiku-apps/caya Once you have a working bep file attach it to this trac ticket and I'll add it into Haikuports svn. If you need an example bep file to see how it would needs to be formatted check some of the other bep files in the haiku-apps directory.

comment:5 by Barrett, 9 years ago

Just a question, we have two repositories, one for MIT code (Caya + aim plugin) and another for GPL plugins (xmpp, msn, yahoo)...looking at the beps guide on haikuports seems that it is not possible to have two repositories for one package (correct me if i'm wrong), so i'm doing two bep files one for Caya itself and one for "Caya-gpl-plugins"...only to notice you in case i'm doing something bad.

comment:6 by scottmc, 9 years ago

That should be ok.

by Barrett, 9 years ago

Attachment: caya-haikuports.diff added

patch to build caya with haikuporter

comment:7 by scottmc, 9 years ago

Added to haikuports in 1529, but it's not building cleanly. Barrett, perhaps you can try it on a fresh install and see if there's any other dependencies other than curl that I might have missed. Let's leave this open until we verify it's building right and gets added into the OptionalPackages.

comment:8 by Barrett, 9 years ago

Maybe the problem is that Caya need gcc4, is there a method to disable gcc2 builds or something?

comment:9 by scottmc, 9 years ago

ok, gcc4 worked, but there's a handful of warnings you may want to investigate. I got: application/views/ContactPopUp.cpp:19 warning: the result of the conversion is unspecified because '1025' is outside the range of type 'windoew_feel' and a few others.

I'll update the .bep to mark it as gcc4 only.

comment:10 by scottmc, 9 years ago

caya builds, but then caya-gpl-protocol is complaining that the Caya library is needed! Is there a specific location this needs to be located for the gpl-protocols to build?

in reply to:  10 comment:11 by scottmc, 8 years ago

Replying to scottmc:

caya builds, but then caya-gpl-protocol is complaining that the Caya library is needed! Is there a specific location this needs to be located for the gpl-protocols to build?

@Barrett, Now that GSoC is over, maybe you can take another look at this when you find time and suggest what to do next?

comment:12 by pulkomandy, 8 years ago

Cc: pulkomandy added

by Barrett, 8 years ago

Attachment: caya-haikuports.2.diff added

Patch fixing the problems with caya's bep file

comment:13 by Barrett, 8 years ago

Hello, sorry for delay...i had completely forgotten this task. I have attached a patch that fix the problem.

by scottmc, 8 years ago

Attachment: CayaOptionalPackages.diff added

patch to add caya as an optional package

comment:14 by scottmc, 8 years ago

@Barrett, I have attached a diff to allow for adding caya into haiku as an optional package. Please use this to patch your OptionalPackages file and then build caya into Haiku. Verify everything works as expected, including checking of the About System copyright entries, as I'm not sure how they will show up for this one since there are two entries. Make sure everything is in order and if not fix up what needs fixing and let me know. If you need to update the .bep file(s) please open a new ticket on HaikuPorts and attach them there.

comment:15 by pulkomandy, 8 years ago

I tried to build it, but Caya hrev240 crashes on startup. (gcc2hybrid). So I'd suggest we don't make it available yet :)

comment:16 by Barrett, 8 years ago

Have you compiled all with gcc4? Which rev of caya-gpl-protocols are you using? Looks strange, you are the first person telling me about a crash on startup. It seems something like old plugins in the install directory.

comment:17 by pulkomandy, 8 years ago

#1  0x01d9348c in initialize_before () from /boot/system/lib/libnetwork.so
#2  0x01d932ea in __haiku_init_before () from /boot/system/lib/libnetwork.so
#3  0x01d929d7 in _init () from /boot/system/lib/libnetwork.so
#4  0x0010090c in init_dependencies () from /boot/system/runtime_loader
#5  0x00101064 in load_library () from /boot/system/runtime_loader
#6  0x00104222 in export_load_add_on () from /boot/system/runtime_loader
#7  0x0061d11e in load_add_on () from /boot/system/lib/gcc4/libroot.so

Is there something else to clean besides /boot/common/apps ?

comment:18 by Barrett, 8 years ago

No, all caya binaries are contained in /boot/apps/Caya/. There are just some headers installed, but they aren't the problem. Are you using alpha3?

comment:19 by pulkomandy, 8 years ago

No, this is hrev43105. I think it was working in the alpha...

in reply to:  19 comment:20 by Barrett, 8 years ago

Ok, i'll look at it. Yes it's working as well on alpha3.

comment:21 by scottmc, 8 years ago

What's the status on this one?

comment:22 by Barrett, 8 years ago

I'm close to release a new prealpha, so i've planned to begin with the optional package with that release. At the moment i've finished the work on Caya itself, in the next days i'll send a patch to the haikuports trac.

comment:23 by korli, 8 years ago

Was there something submitted on HaikuPorts?

comment:25 by mmadia, 8 years ago

Owner: changed from scottmc to mmadia

Barrett has provided me with some updated archives. I'll be updating OptionalPackages shortly.

comment:26 by mmadia, 8 years ago

Has a Patch: unset

comment:27 by mmadia, 8 years ago

Has a Patch: set

comment:28 by mmadia, 8 years ago

Resolution: fixed
Status: assignedclosed

Added in hrev44193. Thanks!

Note: See TracTickets for help on using tickets.