Opened 8 years ago

Closed 8 years ago

#7448 closed bug (fixed)

Touchpad sucking CPU when touched

Reported by: humdinger Owned by: czeidler
Priority: normal Milestone: R1
Component: Drivers/Mouse/PS2 Version: R1/Development
Keywords: synaptics, touchpad Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev41255.

Probably since the recent work on the synaptics/touchpad, input_servers "Ps/2 Touchpad 1" thread consumes about 15% CPU in my Core2Duo when the touchpad is in use. I don't think there was a visible usage-increase before...

Attachments (4)

top_usb_mouse_old.txt (1.8 KB) - added by taos 8 years ago.
top_usb_mouse.txt (1.6 KB) - added by taos 8 years ago.
top_touchpad_old.txt (1.8 KB) - added by taos 8 years ago.
top_touchpad.txt (1.6 KB) - added by taos 8 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by czeidler

Could you please check if it really comes from my changes? Can't imagine where this should could come from. Can't see the usage increase with ALPS...

thx!

comment:2 Changed 8 years ago by taos

Using hrev41256 (gcc2hybrid) with an old centrino notebook (Pentium M 1,3 GHz, 1280 MB RAM) with Synaptics Touchpad.

Top command in terminal shows a cpu usage of

  • ca. 15 % for thread "Ps/2 Touchpad 1 watcher", while using 2-finger-scrolling with touchpad (see "top_touchpad.txt").
  • < 1 % for thread "USB Mouse 1 watcher", while using scroll wheel of usb mouse (see "top_usb_mouse.txt").

For comparison, the output of top with hrev37573:

  • < 1 % for 2-finger-scrolling with touchpad (see "top_touchpad_old.txt")
  • < 1 % for scrolling with usb mouse (see "top_usb_mouse_old.txt")

Changed 8 years ago by taos

Attachment: top_usb_mouse_old.txt added

Changed 8 years ago by taos

Attachment: top_usb_mouse.txt added

Changed 8 years ago by taos

Attachment: top_touchpad_old.txt added

Changed 8 years ago by taos

Attachment: top_touchpad.txt added

comment:3 Changed 8 years ago by humdinger

I tried the nightly hrev41185, but couldn't get it to finish the bootup, because of that synaptics crash you have fixed with a later commit.
I then went further back to hrev41122, which should be before all your touchpad works. That one boots up and shows a CPU usage of just 0.1%, similar to taos' findings. It seems something of your changes did do the damage. :)

comment:4 Changed 8 years ago by humdinger

When using the touchpad, I have my syslog filled with tons and tons of things like

KERN: ALPS: movement set buttons
KERN: ALPS: tap gesture timed out
KERN: ALPS: movement event
KERN: ALPS: movement set buttons
KERN: ALPS: tap gesture timed out
KERN: ALPS: no touch event
KERN: ALPS: tap drag gesture timed out
KERN: ALPS: tap gesture timed out
KERN: ALPS: no touch event
KERN: ALPS: tap drag gesture timed out
KERN: ALPS: tap gesture timed out

May this excessive debugging info be the cause of the CPU suckage?

comment:5 Changed 8 years ago by czeidler

ah jetzt ja! that sounds like the only reasonable explanation. Could you check my last commit? thanks!

comment:6 Changed 8 years ago by humdinger

Perfect! That was it, everything's back to normal, i.e. 0.1% usage. Thanks very much!

comment:7 Changed 8 years ago by czeidler

Resolution: fixed
Status: newclosed

cool

Note: See TracTickets for help on using tickets.