Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#7452 closed bug (duplicate)

intel pro100 not recognized by haiku

Reported by: Jack Perry Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hiho

I have an HP Pavilion 7965 that I'd like to try running Haiku on. It boots up fine and many programs work great.

However, the network doesn't work at all. With lspci --vvnn, Linux reports

02:08.0 Ethernet controller [0200]: Intel Corporation 82801BA/BAM/CA/CAM Ethernet Controller [8086:2449] (rev 03)
        Subsystem: Intel Corporation EtherExpress PRO/100 VE [8086:3013]                                         
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-    
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- SERR- 
        Kernel driver in use: e100
        Kernel modules: e100

But Haiku's Network Preferences app (system->preferences->network) doesn't seem to recognize it at all.

I'm happy to give more information, but I'm completely new to Haiku and don't know what to do.

Attachments (3)

drivers.txt (1.3 KB) - added by Jack Perry 8 years ago.
output of listimage | grep drivers
listdev.txt (1.6 KB) - added by Jack Perry 8 years ago.
output of listdev
syslog.txt (157.6 KB) - added by Jack Perry 8 years ago.
output of system log

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by Disreali

What revision of Haiku are you using? is it a hybrid? If you are using Alpha2, I would recommend re-installing the most recent nightly that is available at http://haiku-files.org/, as Alpha2 is quite old.

There are a couple nicely written guides to bug reporting here and on the HaikuTrac wiki.

Easiest way to get relevant info on Haiku is to open a Terminal window and type the following:

listdev > ~/listdev.txt

listimage | grep drivers/ > ~/drivers.txt

You now can attach those files to this ticket to help the other diagnose your systems issue.

Last edited 8 years ago by Disreali (previous) (diff)

comment:2 Changed 8 years ago by Jack Perry

Thanks! That was fast. :-)

Yes, I'm using Alpha2. I'll try a nightly, then go through the bug reporting process and see what happens. It'll probably be a few days before I can get around to it, but I'll be back.

Changed 8 years ago by Jack Perry

Attachment: drivers.txt added

output of listimage | grep drivers

Changed 8 years ago by Jack Perry

Attachment: listdev.txt added

output of listdev

Changed 8 years ago by Jack Perry

Attachment: syslog.txt added

output of system log

comment:3 Changed 8 years ago by Jack Perry

I just attached a number of files. syslog.txt seemed to contain the most interesting information; the system recognizes the device, but seems to fail when loading ipv6. FWIW, calling up Network preferences fails immediately.

comment:4 Changed 8 years ago by korli

It seems your network device wasn't configured by the BIOS, ie the interrupt configured is 0xff. Can you check if a BIOS option "PnP OS installed" is ON ?

comment:5 Changed 8 years ago by Jack Perry

The BIOS option "Plug & Play OS" is marked "Yes". Linux (Fedora anyway) has no problem recognizing the card and initializing the network.

Last edited 8 years ago by Jack Perry (previous) (diff)

comment:6 Changed 8 years ago by anevilyak

Try setting it to no. That will tell the BIOS to fully configure all devices, which should help here.

comment:7 Changed 8 years ago by Jack Perry

Setting it to no worked! I was able to log in to my computer at work via ssh and do something. :-) It also works in alpha 1, which is where I'm typing it now (nightly wouldn't run WebPositive).

Thanks!!! :-)

comment:8 Changed 8 years ago by anevilyak

Blocked By: 5 added
Resolution: duplicate
Status: newclosed

Cool, that makes this a dupe of #5. Enjoy!

comment:9 Changed 6 years ago by scottmc

Blocked By: 5 removed

(In #5) All but one of the blocking tickets have been closed out, and that one just needs confirmation as to whether it's been fixed or not. So I say let's close this one out as being fixed, seeing as the reported symptoms have gone away.

Note: See TracTickets for help on using tickets.