Opened 9 years ago

Closed 4 years ago

#7456 closed bug (invalid)

Terminal memory leak

Reported by: jonas.kirilla Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Terminal Version: R1/Development
Keywords: gci2011 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

An idle Terminal can show slowly rising memory use. Possibly related to tab title updates, which is a periodic event.

I think it can be triggered by opening a full set of tabs and running something long enough to results in tab resizing, e.g. "sleep 3", but I'm not entirely certain about it.

Change History (3)

comment:1 by pepol, 8 years ago

Keywords: gci2011 added

The problem was checked during GCI 2011. Seems to be a bug also on hrev43238.
Three tabs opened in Terminal, when I first checked, it used 3.28MB of memory, few minutes of being idle later, 3.39MB and rising.

comment:2 by jackburton, 5 years ago

I tried to reproduce on a current revision (hrev48742) but couldn't. Granted, it's a gcc4 build, but Terminal with three tabs opened uses 1,59MB and stays like that for all the time.

comment:3 by jackburton, 4 years ago

Resolution: invalid
Status: newclosed

Not reproducible, and no reply since 6 months (or more). Please reopen if you have a method to reproduce it consistently.

Note: See TracTickets for help on using tickets.