Opened 13 years ago

Closed 12 years ago

#751 closed bug (fixed)

[kernel] PANIC if all apps in /boot/beos/bin opened at once

Reported by: diver Owned by: axeld
Priority: blocker Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

Tested with hrev18522 under vmware. Go to /boot/beos/bin, selecat all (alt+a) end press enter. After several seconds Haiku will crash. Stack crawl will follow...

Attachments (2)

kdl_4.PNG (28.4 KB ) - added by diver 13 years ago.
kdl
serial.txt (36.5 KB ) - added by diver 13 years ago.
syslog

Download all attachments as: .zip

Change History (10)

comment:1 by diver, 13 years ago

severity: normalblocker

by diver, 13 years ago

Attachment: kdl_4.PNG added

kdl

comment:2 by diver, 13 years ago

Platform: All

Now, it could crash on route or just makes screen white (gdb not loaded)

comment:3 by netster403, 13 years ago

related to bug #698?

comment:4 by axeld, 13 years ago

Description: modified (diff)

Can you still reproduce this? It doesn't happen anymore over here. (Probably since hrev19549 or hrev19571)

comment:5 by diver, 13 years ago

Yes, it's still happens with hrev19802 under vmware. This time when it crashed i just saw white screen, then i pressed F12 and typed sc (no letters were printed).

by diver, 13 years ago

Attachment: serial.txt added

syslog

comment:6 by diver, 13 years ago

Sometimes on white screen i see how procescontroller's replicant draws through. In some other cases i see several windows with "Too many opened applications" message, few of this windows have a warning image, but others don't, out of resources?

comment:7 by aldeck, 12 years ago

Can't reproduce, other minor bugs (see below) but, no kernel panic, testing on hrev21836.

Not really a proper test case anyway, running /boot/beos/bin apps that way. For example running /boot/beos/bin/consoled gives a redraw and input issue (what's consoled supposed to do?). Anyway, to put it short, this bug is too vague (and too old) and even not reproducible, should be closed. For more precise testing new bugs should be filled imho :)

comment:8 by axeld, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.