Opened 8 years ago

Closed 8 years ago

#7511 closed bug (fixed)

[kernel] doesn't boot in VirtualBox with io-apics enabled

Reported by: diver Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev41536 hangs at disk icon

hrev41530-hrev41535 grep routing /var/log/syslog KERN: IRQ routing preparation failed, not configuring io-apics

hrev41528-hrev41529 hangs at disk icon

hrev41527 grep routing /var/log/syslog KERN: using io-apics for interrups routing

Attachments (3)

syslog_r41536.txt (24.4 KB) - added by diver 8 years ago.
syslog_without_usb_r41551.txt (15.6 KB) - added by diver 8 years ago.
syslog_with_usb_r41551.txt (16.7 KB) - added by diver 8 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by stargatefan

did you try with vmware vmplayer free?? ? I have always had problems with virtualbox ?

comment:2 Changed 8 years ago by nielx

Owner: changed from axeld to mmlr
Status: newassigned

comment:3 in reply to:  description Changed 8 years ago by mmlr

Replying to diver:

hrev41527 grep routing /var/log/syslog KERN: using io-apics for interrups routing

Interesting, that's the first revision with IO-APIC default on (which definitely worked fine on my end as well). So implementing source overrides in hrev41528 seems to be the cause.

I broke IO-APICs due to non-initialized NMI sources in hrev41530 and fixed that again in hrev41535, so that explains that range.

I will try to reproduce this later, but right now I don't have the time. If you could attach a serial log from such a hanging boot (you need to configure VirtualBox to write that into a file), that'd be most appreciated.

Changed 8 years ago by diver

Attachment: syslog_r41536.txt added

comment:4 Changed 8 years ago by mmlr

That's really strange. I'm running VirtualBox 4.0.8 (r 71778) here and I tried replicating your exact setup (device configuration according to the PCI config in your log).

But when I run that I get two extra mappings in the IRQ routing table and two source overrides that aren't shown in your log. On the other hand your log seems to be missing some lines of the PCI dump as well, so maybe something got lost? In any case I was unable to replicate a hang with any combination of settings I tried. Can you tell me in detail what your configuration looks like? It is a pretty elaborate configuration BTW, nowhere near a "default" VirtualBox config I've seen so far.

Is it possible that you migrated those settings over a couple of VirtualBox versions maybe? Does it still happen if you set up a new VM with the same Haiku disk?

comment:5 Changed 8 years ago by diver

This is hrev41551 in VirtualBox 3.0.12.

It still happens after creating new VM. It hangs at the 3rd icon (card) unless I disable USB support in the VM. Without USB support it hangs at the 4th (disk) icon.

Last edited 8 years ago by diver (previous) (diff)

Changed 8 years ago by diver

Changed 8 years ago by diver

Attachment: syslog_with_usb_r41551.txt added

comment:6 in reply to:  5 Changed 8 years ago by mmlr

Replying to diver:

This is hrev41551 in VirtualBox 3.0.12.

I've now rechecked with my older install (at work) that is 3.2.12 (r 68302) and I still can't reproduce it in any way. I'm therefore inclined to say this is a VirtualBox bug that got fixed in newer versions. As the IO-APIC isn't really necessary in VirtualBox (it even tells that it'll degrade performance slightly) and since it isn't enabled by default, I would like to close this as invalid. What do you say diver?

comment:7 Changed 8 years ago by diver

Fine by me, feel free to close.

comment:8 Changed 8 years ago by mmlr

Resolution: invalid
Status: assignedclosed

Closing as a bug in earlier VirtualBox versions in that case.

comment:9 Changed 8 years ago by diver

For the record: it works again in hrev41693.

comment:10 in reply to:  9 Changed 8 years ago by mmlr

Resolution: invalid
Status: closedreopened

Replying to diver:

For the record: it works again in hrev41693.

I see, so it was the inverted interrupt handover between PIC and IO-APIC. A bit strange that it'd hang in VirtualBox, but it was definitely a bug.

comment:11 Changed 8 years ago by mmlr

Resolution: fixed
Status: reopenedclosed

Fixed in hrev41685.

Note: See TracTickets for help on using tickets.