Opened 8 years ago

Last modified 4 months ago

#7522 new bug

Intel D525 motherboard not able to boot haiku from partition on flash drive

Reported by: 6foot3 Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have a 4GB flash drive with two partitions on it, one 1GB for haiku and the rest (2.75GB) as a FAT32 partition with a live Ubuntu 10.04 installed. It has grub installed on the MBR with the option to boot haiku or linux. For details of how the drive was prepared see: http://www.freelists.org/post/haiku-development/booting-from-partition-on-flash-drive,12 . As stated on that mailing list thread I found that arrangement to be quite valuable for testing since if haiku didn't boot, I could always try linux. I recently upgraded from my Intel D945GCLF2 to a D525MW motherboard and have been unable to boot from this flash drive into haiku. When I select haiku from the grub boot menu, I get the haiku boot loader menu with the line "select boot volume (current:none)" highlighted. Hitting enter takes me to the "Select Boot Volume" screen where the only choice is the haiku a partition on the hard disk. The boot loader appears not to be finding the haiku partition on the flash drive. This method works on my netbook which is quite similar to the new motherboard and was tested earlier using an R1/a3rc (41552).

Attachments (1)

listdev output.txt (2.4 KB) - added by 6foot3 8 years ago.

Download all attachments as: .zip

Change History (18)

Changed 8 years ago by 6foot3

Attachment: listdev output.txt added

comment:1 Changed 8 years ago by 6foot3

Using the same flash drive I use for testing ticket #7523, hrev40033 also boots on this system (D525MW). I didn't do much checking in between but, hrev41490 did not boot and as far back as hrev40188 probably did not boot either. Would check now but I've run out of play time and have got to get back to real life!

comment:2 Changed 8 years ago by 6foot3

Version: R1/DevelopmentR1/alpha3

comment:3 Changed 8 years ago by 6foot3

Over the past couple of weeks I've been doing some more testing of these partitioned flash drives. The 4GB with the 1GB BFS partition as the first partition still does not boot as of hrev41861. I also have a 2GB Sandisk Cruzer with a 1GB FAT32 partition asd the first partition, the rest being a BFS partition. I had installed Ubuntu Live on it using Ubuntu 10.04 which uses GRUB2 and thus messed up my little boot loading arrangement. I needed to do some work with GRUB on a particular sysytem so I restored the GRUB bootloader on this flash drive, after which not only would it boot Ubuntu but, the Haiku installation on the second partition as well. Every revision of Haiku that I've tried boots, including those that do not work on the flash drive that has Haiku on the first partition.

Is there any more information I can provide that might help to find why the bootloader can't find the BFS partition on this flash drive when using this particular motherboard?

Last edited 8 years ago by 6foot3 (previous) (diff)

comment:4 Changed 8 years ago by 6foot3

On the other hand, I see from the main development mailing list that the boot code may be in for a fairly substantial change see: http://www.freelists.org/post/haiku-development/haiku-loader-never-appears-on-my-screen-resolved .

Not being a developer, how can I get my hands on a build with this new boot code for testing?

comment:5 Changed 8 years ago by mmadia

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

comment:6 Changed 8 years ago by diver

It would be nice if you could find which revision broke booting.
It worked in hrev40033 and doesn't in hrev40188, right?
Try using wiki:BinarySearch for that.

comment:7 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:8 Changed 8 years ago by 6foot3

Just tested hrev40188 to be sure and right, hrev40188 brings up the "select boot volume (current:none)" issue. Checked the commits list and there was some work done on the bootloader from between hrev40064 to hrev40076. There were also some changes to /boot/platform/bios_ia32 between hrev40077 and hrev40079 but, I don't know if that has anything to do with this issue.

comment:9 Changed 8 years ago by bonefish

I skimmed through the boot loader changes in that range and those only seem to be fixes for Coverity tickets. A good deal of them should have no effect at all, others are only "to be on the safe side". It would indeed help a great deal if you could binary search the culprit. If you don't build your images yourself you could start with hrev40145 and maybe someone can build the images for the next steps for you.

comment:10 Changed 8 years ago by 6foot3

hrev40145 doesn't work so it's somewhere between there and hrev40033. There are no raw images on haiku-files.org between hrev40145 and hrev39217 so, if anyone could provide me with a build of say hrev40084, we could start there. I really should bite the bullet and set up a build system and learn to build images myself but, I don't know how long it'l take me to figure it all out.

comment:11 Changed 8 years ago by bonefish

I've built a bare bones gcc2 image for you: http://www.yellowbites.com/downloads/haiku-r40089.image.gz

comment:12 Changed 8 years ago by bonefish

I also built the two images of which one will be needed for the next binary search step (XZ compressed this time):

comment:13 Changed 7 years ago by 6foot3

OK guys, sorry about the long break but, I was getting confused by the results I was getting from testing. The only explanation that makes any sense to me is that I made a major error in assuming that hrev40033 successfully booted from the flash drive on this D525MW motherboard. Since this system is one that I have upgraded from a Intel D945GCLF2 to the D525MW motherboard, my guess is that hrev40033 is the last revision I installed before the upgrade. As indicated above, nothing I have tried boots on this motherboard including hrev40033. I have tried changing any BIOS settings that have even a remote chance of making a difference with no success. As stated before Ubuntu Linux (9.04 and 10.04) and Windows 7 all boot OK. I have a Windows XP USB drive that I have not tested yet.

I am thinking maybe I could donate one of these motherboards to a any developer who could figure this out, if that would help. My sincere apologies to bonefish for wasting your time.

comment:14 Changed 7 years ago by 6foot3

I tried booting a 2GB USB stick that i set up for booting up into the windows XP install and it works. As of now, haiku is the only OS that I have tried to boot on this motherboard that does not boot.

comment:15 Changed 9 months ago by waddlesplash

Keywords: boot-failure added

comment:16 Changed 9 months ago by waddlesplash

Blocking: 7665 removed

comment:17 Changed 4 months ago by waddlesplash

Still an issue?

Note: See TracTickets for help on using tickets.