Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7543 closed bug (fixed)

[ReadOnlyBootPrompt] When changing language welcome message is not translated

Reported by: taos Owned by: bonefish
Priority: high Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: localization Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using r1a3-rc-hrev41612.

When choosing a language different from English in ReadOnlyBootPrompt the welcome message on the right is not changed.

Partially localized ReadOnlyBootPrompt.

The length of the translation string was fixed in hrev41542 (#7494), and the current catkeys (at least for Swedish and German) were merged with alpha 3 branch in hrev41609.

Attachments (1)

Welcome_to_Haiku.png (33.6 KB) - added by taos 8 years ago.
Partially localized ReadOnlyBootPrompt.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by taos

Attachment: Welcome_to_Haiku.png added

Partially localized ReadOnlyBootPrompt.

comment:1 Changed 8 years ago by deejam

I also spoted this bug. This is the first the users will see when trying out Haiku. The priority should be raised on this one and added to the alpha3 milestone.

comment:2 Changed 8 years ago by mmadia

Owner: changed from stippi to axeld
Priority: normalhigh
Status: newassigned

comment:3 Changed 8 years ago by bonefish

Component: Applications/ReadOnlyBootPromptKits/Locale Kit
Owner: changed from axeld to bonefish
Status: assignedin-progress

Caused by BHashMapCatalog::SetString() not processing escaped character in the comment string.

comment:4 Changed 8 years ago by bonefish

Resolution: fixed
Status: in-progressclosed

Fixed in hrev41629.

comment:5 Changed 8 years ago by mmadia

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

Note: See TracTickets for help on using tickets.