Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7612 closed bug (invalid)

SVN Not Working In Alpha 3 Pre-Release

Reported by: tonestone57 Owned by: bonefish
Priority: high Milestone: R1/alpha3
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Image downloaded from haiku-files. Haiku ISO hrev41789 (same for hrev41759). Running ISO LiveCD in VirtualBox.

svn, "command not found", installoptionalpackage, "no packages need to be installed"

I removed installoptionalpackage cache to re-install svn, then ran installoptionalpackage subversion, svn installed, svn, "runtime_loader cannot open file libaprutil-1.so.0: no such file or directory"

Someone else should also track issue in case I cannot.

Change History (4)

comment:1 by scottmc, 8 years ago

Milestone: R1R1/alpha3
Priority: normalhigh

I'm not able to reproduce this here. I'm using hrev41789 also, but the raw image, and it's working as expected. So this could be an issue with the ISO image then.

comment:2 by tonestone57, 8 years ago

I just grabbed anyboot hrev41789 and svn appears to work on that. Since you say it works on raw too then I guess only ISO issue. I was just lucky enough to get hit by this bug because I usually stick to anyboot.

Not only does testing have to happen for all the optional packages but also on all the different versions - ISO, anyboot, vmware & raw as you can see from this ticket.

Grab the ISO version & see for yourself.

comment:3 by mmadia, 8 years ago

Resolution: invalid
Status: newclosed

The ISO is more of a 'reduced functionality' live CD. Certain packages are stored as their compressed archives and are extracted to the boot volume via Installer. This is the reason why using the ISO with virtual box is strongly discouraged.

comment:4 by tonestone57, 8 years ago

Ok, I see what you mean. I looked in ISO packages folder and saw some CLI programs & libraries zipped up in there to save space. In anyboot there is no packages folder and likely same for the other ones. I still was able to install couple things like beae, clockwerk, netsurf, beam but not others.

Should add a note to haiku-files and to get-haiku like "ISO LiveCD provides reduced functionality compared to the other formats." That way more people know this.

Thanks Scott & Matt. Later,

Note: See TracTickets for help on using tickets.