Opened 9 years ago

Closed 7 years ago

#7620 closed bug (fixed)

Crash in webpositive on mozzila page easily reproduced.

Reported by: stargatefan Owned by: leavengood
Priority: normal Milestone: R1/beta1
Component: Applications/WebPositive Version: R1/Development
Keywords: crash Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by scottmc)

easily reproduced crash. Link to page is in text file with crash info.

https://donate.mozilla.org/page/contribute/protect-the-web

just visit this page with webpositive, crashes every time on the alpha3 RC hrev41789.

Attachments (2)

New text file (5.9 KB ) - added by stargatefan 9 years ago.
complete_bt.txt (12.7 KB ) - added by taos 9 years ago.
Complete bt

Download all attachments as: .zip

Change History (10)

by stargatefan, 9 years ago

Attachment: New text file added

by taos, 9 years ago

Attachment: complete_bt.txt added

Complete bt

comment:1 by phoudoin, 9 years ago

According WebKit bug database, I fear that's an issue in the WebKit revision we're using, that was fixed since by WebKit project.

Which leads to the heavy task to resync with a more recent WebKit revision... or move WebPositive to WebKit project.

comment:2 by scottmc, 9 years ago

Description: modified (diff)
Milestone: R1R1/alpha3
Priority: normalhigh

Well if it's been fixed in upstream webkit, and we need a fresh webpositive build for alpha3 anyways, I'm setting this to an alpha3/high.

in reply to:  2 comment:3 by anevilyak, 9 years ago

Replying to scottmc:

Well if it's been fixed in upstream webkit, and we need a fresh webpositive build for alpha3 anyways, I'm setting this to an alpha3/high.

It's not quite that simple, the Webkit build that Web+ is based off is somewhere around a year and half old at this point, if not more. Syncing it up is not a trivial task because quite a few things have changed drastically and the Haiku portions of it have not been maintained to keep up (WebKit doesn't generally care about backwards compat). It could quite literally be several weeks if not a month of full time work to get it back up to date, so I wouldn't flag this as an alpha priority.

comment:4 by leavengood, 9 years ago

Yeah there is no way I can get this fixed for alpha3, I barely have time to make a build. But updating our WebKit is definitely a high priority for me. Since I probably have the most experience updating WebKit and dealing with all the changes from when I first did the port (though I'm sure Stephan did his share too) it hopefully shouldn't take me too long.

There are several steps involved though, but the first is just getting our WebKit updated. The others include trying to reuse one of the other WebKit build systems (likely Gyp) and then getting our changes upstream. The latter could be quite a chore, though I hope to convince the WebKit people to be a little less picky with our first set of patches, especially for just our platform files.

comment:5 by scottmc, 9 years ago

Milestone: R1/alpha3R1/beta1
Priority: highnormal

ok, let's slide this ticket to beta1, but we still need that fresh build for alpha3...

comment:6 by mmadia, 9 years ago

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

comment:7 by mmadia, 7 years ago

Hi. Our WebKit port (and thus WebPositive) was updated in July. Could you retest this in a new nightly image and report back? http://www.haiku-files.org/haiku/development Thanks!

comment:8 by leavengood, 7 years ago

Resolution: fixed
Status: newclosed

I tested and this page does not crash with the latest WebKit, but it does not look very good. But I think most of the rendering issues are very evident on most other pages so this can be closed.

Note: See TracTickets for help on using tickets.