Opened 9 years ago

Closed 7 months ago

Last modified 5 months ago

#7624 closed enhancement (fixed)

Menu drawing order

Reported by: cipri Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Kits/Interface Kit Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description (last modified by diver)

If a BMenuBar is above a BGLView then opening a menu and moving to the next menu has a bad visible effect (because of redrawing the BGLView which takes time). To see better what i mean, take that program from http://depot.haiku-os.org/puri and now open a menu let's say "Engine" then move to the right to "Tools".

I think that problem could be solved, if "BMenuBar" would be drawn first (because it doesn't overlap anything else) and then the BMenuItem. Because in the current situation if you move from one menu to another, the menuitem are drawn, they overlap the BGLView this causes the BGLView to redraw and this takes time and just after that the menubar redraws. I just guess, since i didn't look at the source code.

Change History (5)

comment:1 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:2 by diver, 8 months ago

Description: modified (diff)
Summary: Order of Drawing Menu.Menu drawing order

Still an issue?

comment:3 by X512, 7 months ago

It is not possible to easily change window drawing order, because each window is running in own thread and drawing order is undefined.

No artifacts are observed on fast hardware in hrev53903. Probably can be closed as no change required.

comment:4 by diver, 7 months ago

Resolution: fixed
Status: assignedclosed

Can't reproduce either. Closing.

comment:5 by nielx, 5 months ago

Milestone: R1R1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.