Opened 8 years ago

Closed 3 years ago

Last modified 10 months ago

#7628 closed bug (fixed)

Boot fails unless IO-APIC is disabled in boot menu

Reported by: gerald.zajac Owned by: mmlr
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc: greggd@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When booting a computer with an MSI K7T Turbo2 motherboard, AMD Athlon XP 2000+ CPU, and 512 MB memory, the boot fails immediately after the boot screen is displayed. If IO-APIC is disabled in the boot menu, the computer boots and runs okay.

This was tested with hrev41843; however, earlier versions also had this problem.

Attachments (6)

K7T_syslog (19.5 KB) - added by gerald.zajac 8 years ago.
My hardware from lspci in Ubuntu.txt (2.2 KB) - added by HAL 7 years ago.
My hardware from lspci in Ubuntu
100_0479.JPG (1.2 MB) - added by HAL 7 years ago.
Debug screen 1 local apic enebled
100_0480.JPG (1.6 MB) - added by HAL 7 years ago.
Debug screen 2 local apic enabled
100_0481.JPG (1.6 MB) - added by HAL 7 years ago.
Debug screen 3 local apic enabled
100_0482.JPG (1.6 MB) - added by HAL 7 years ago.
Debug screen 4 local apic enabled

Change History (20)

Changed 8 years ago by gerald.zajac

Attachment: K7T_syslog added

comment:1 Changed 8 years ago by anevilyak

Owner: changed from axeld to mmlr
Status: newassigned

comment:2 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:3 Changed 7 years ago by pulkomandy

I have a similar problem with a DFI AD77 motherboard and Athlon XP 2200+. (Via KT400A and VT8235 chipset) Does checking "disable local APIC" in the boot menu work too ?

comment:4 in reply to:  3 Changed 7 years ago by mmlr

Replying to pulkomandy:

Does checking "disable local APIC" in the boot menu work too ?

It most certainly does, as disabling the local APIC disables all the things that depend on it (APIC timers, IO-APIC, IPIs and therefore SMP, some local interrupts for thermal / power management we don't do yet).

comment:5 Changed 7 years ago by pulkomandy

Likely fixed by hrev43217 ? (see #8102 )

comment:6 in reply to:  5 Changed 7 years ago by mmlr

Replying to pulkomandy:

Likely fixed by hrev43217 ? (see #8102 )

Definitely not. The system in this report does do the MP config using ACPI and the configuration is valid. The problem is much further down, where the current configuration of an interrupt link device is being read. That fails so that it's not really possible for the interrupt code to properly set up the interrupt routing. The system should continue to boot (falling back to PIC mode instead of (IO-)APIC) by simply continuing out of that panic. Possibly the link device in question isn't enabled and if not actually needed doesn't need to provide the current config. Other than that an initial configuration might be inferable by some other means, but I'll need to look into that again.

comment:7 Changed 7 years ago by HAL

Cc: greggd@… added

comment:8 Changed 7 years ago by HAL

I have the same bug but my syslog does not seem to match the reporters syslog. I'm thinking it should match at least in a general sense, because of different hardware. To get my syslog I started boot into safe mode options, made sure syslog was selected in debug options and returned to boot menu without disabling local apic. The system froze at the middle boot icon. I then did a hardware reset and boot with local apic disabled, also had the syslog disabled in debug options, for this boot. Would the syslog be generated and remembered for the boot with local apic enabled, since it is neccessary for the reset?

comment:9 Changed 7 years ago by HAL

How do I get a syslog for booting when local apic is enabled?

Changed 7 years ago by HAL

My hardware from lspci in Ubuntu

comment:10 Changed 7 years ago by HAL

I will upload photos of debug screens with local apic enabled.

Changed 7 years ago by HAL

Attachment: 100_0479.JPG added

Debug screen 1 local apic enebled

Changed 7 years ago by HAL

Attachment: 100_0480.JPG added

Debug screen 2 local apic enabled

Changed 7 years ago by HAL

Attachment: 100_0481.JPG added

Debug screen 3 local apic enabled

Changed 7 years ago by HAL

Attachment: 100_0482.JPG added

Debug screen 4 local apic enabled

comment:11 Changed 7 years ago by diver

Milestone: UnscheduledR1

The last message from 100_0482.JPG is:

usb ohci -1: smm is in control of the host controller

what could be related to #8085 or #3999.

Last edited 7 years ago by diver (previous) (diff)

comment:12 in reply to:  11 Changed 7 years ago by HAL

Replying to diver:

The last message from 100_0482.JPG is:

usb ohci -1: smm is in control of the host controller

what could be related to #8085 or #3999.

That is probably correct at least for bug #3999. As with that bug disabling C1E in the BIOS enabled Haiku to boot for me. I also tried, "I hit the power button instead of the reset one. And the boot continued!!" that the reporter stated. That did not work for me.

Last edited 7 years ago by HAL (previous) (diff)

comment:13 Changed 3 years ago by kallisti5

Resolution: fixed
Status: assignedclosed

lots and lots of core kernel + driver + usb changes since this one was opened. Please re-open if the same issue still exists on the same hardware chipset.

comment:14 Changed 10 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.