Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7688 closed bug (fixed)

Building r42185 (trunk) in Alpha3-RC fails

Reported by: taos Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using r1a3-hrev42159.

Building hrev42185 (trunk) fails with "/private/storage/storage_support.h: No such file or directory".

Terminal output is attached ("BuildFailure.txt").

Attachments (1)

BuildFailure.txt (3.6 KB ) - added by taos 8 years ago.
Terminal output.

Download all attachments as: .zip

Change History (9)

by taos, 8 years ago

Attachment: BuildFailure.txt added

Terminal output.

comment:1 by stargatefan, 8 years ago

is this a multicore cpu ? If so in pulse under demos, try disabling all but one core. If that works, then this ticket is a duplicate of mine and I get similar problems.

in reply to:  1 ; comment:2 by anevilyak, 8 years ago

Replying to stargatefan:

is this a multicore cpu ? If so in pulse under demos, try disabling all but one core. If that works, then this ticket is a duplicate of mine and I get similar problems.

It has nothing to do with your problem, it's due to some header reorganization that was done earlier today.

in reply to:  2 comment:3 by stargatefan, 8 years ago

Replying to anevilyak:

Replying to stargatefan:

is this a multicore cpu ? If so in pulse under demos, try disabling all but one core. If that works, then this ticket is a duplicate of mine and I get similar problems.

It has nothing to do with your problem, it's due to some header reorganization that was done earlier today.

I frequently get errors like this when I get build fialures and crashs, thats why I asked.

...failed C++ /boot/home/haiku/haiku/generated.x86gcc2/objects/haiku_host/x86/release/tools/database_support.o ... ...removing /boot/home/haiku/haiku/generated.x86gcc2/objects/haiku_host/x86/release/tools/database_support.o

I got these errors at version 42186 on a machine that normally builds just fine. No harm in asking the question. If someone else is having a similar issue it sure doesn't hurt to get more information to resolve my ticket as it may be effecting more then one person..

in reply to:  2 comment:4 by stargatefan, 8 years ago

Replying to anevilyak:

Replying to stargatefan:

is this a multicore cpu ? If so in pulse under demos, try disabling all but one core. If that works, then this ticket is a duplicate of mine and I get similar problems.

It has nothing to do with your problem, it's due to some header reorganization that was done earlier today.

I frequently get errors like this when I get build fialures and crashs, thats why I asked.

...failed C++ /boot/home/haiku/haiku/generated.x86gcc2/objects/haiku_host/x86/release/tools/database_support.o ... ...removing /boot/home/haiku/haiku/generated.x86gcc2/objects/haiku_host/x86/release/tools/database_support.o

I got these errors at version 42186 on a machine that normally builds just fine. No harm in asking the question. If someone else is having a similar issue it sure doesn't hurt to get more information to resolve my ticket as it may be effecting more then one person..

in reply to:  1 comment:5 by taos, 8 years ago

Replying to stargatefan:

is this a multicore cpu ?

No, I'm building haiku on a first generation centrino notebook from early 2003 - neither multicore nor hyperthreading.

BTW, hrev42178 still builds fine - so I think my problem is due to the restructuring of header files in hrev42179 that was mentioned by anevilyak. I'll test again with hrev42179 to be sure.

comment:6 by bonefish, 8 years ago

Status: newin-progress

Sorry, I didn't test my build system changes under Haiku. I didn't think the Haiku build was affected at all. Apparently I was mistaken.

comment:7 by bonefish, 8 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42187.

comment:8 by taos, 8 years ago

Works again. Thanks!

Note: See TracTickets for help on using tickets.