Opened 8 years ago

Closed 7 months ago

#7739 closed bug (invalid)

RTL8168: network down after a few minutes

Reported by: warpdesign2 Owned by: nobody
Priority: normal Milestone: R1
Component: Network & Internet/IPv4 Version: R1/alpha3
Keywords: Realtek 8168 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

After struggling with the CD version (couldn't find a boot partition), I finally made it to Haiku with an usb key :)

Everything seems to be working, except that the network just stops working after a few seconds (can be as little as a minute, up to 5-10 minutes). Ping then stops responding, and I cannot access any site using webpositive (note that I don't even get a network error, cannot reach site,... it just enters an infinite loop).

According to the prefs network panel, I'm using the device: /dev/net/rtl81xx/0

The device listed in the Devices app is:

device/vendor: 0x10ec device/id: 0x8168

I'm using DHCP, and the IP is something like 192.168.... (which appears fine to me).

Change History (6)

comment:1 Changed 8 years ago by diver

Can you check if your ip settings are changing after a few minutes as it could be an issue with dhcp. Also please attach your syslog.

comment:2 Changed 8 years ago by modeenf

Should work with a later build. I hade the same problem.

comment:3 Changed 7 years ago by zooey

Owner: changed from zooey to nobody
Status: newassigned

comment:4 Changed 6 years ago by Kev

I have a similar (the same?) problem, except it usually lasts hours with no trouble, and other times I'll have it happen 2-3 times in a row in few-minute intervals. One workaround I discovered is switching to Static or back to DHCP and clicking Apply (does this restart the net server?). Whatever that triggers, no matter what I've just switched from/to, the network works fine again, Web+ doesn't even need restarting, it just suddenly becomes responsive again. I don't think it's a DHCP issue though, since it happens on Static also (and then is fixed by switching back to DHCP, in that case.)

Up to and including hrev45516 gcc4hybrid. RTL8139.

comment:5 Changed 11 months ago by waddlesplash

Still an issue?

comment:6 Changed 7 months ago by waddlesplash

Resolution: invalid
Status: assignedclosed

No reply in 3 months.

Note: See TracTickets for help on using tickets.