Opened 7 years ago

Closed 6 years ago

#7758 closed bug (invalid)

VirtualBox Intel Network driver not work

Reported by: fano Owned by: Nobody
Priority: normal Milestone: R1
Component: Drivers/Network/ipro1000 Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In Virtual Box 4.0 NONE network card choosable are working!

The default network card is "Intel Pro100 MT Desktop".

Listdev says: 82540EM Gigabit Ethernet Controller (VID 8086 / PID 100e).
It's a pity a lot of people try Haiku in VirtualBox and has a bad impression as network is broken...

Attachments (1)

haiku-vm_working_ipro1000.txt (38.8 KB) - added by taos 7 years ago.
Serial debugging: working ipro1000

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by deejam

What version of VirtualBox and Haiku are you using?

I've never experienced any problems with networking in VirtualBox, which I upgrade continuously (currently at version 4.0.8 hrev71778). The ipro1000 driver was broken in an earlier Haiku nightly build, but this was fixed well in time for alpha 3.

I suspect that this ticket is invalid.

comment:2 in reply to:  description Changed 7 years ago by taos

This configuration works for me, too. Virtual Haiku's WebPositive is connected to the outside world.

Host systems: 1.) Windows 7, 2.) Mandriva 2010.2, 3.) Windows XP
Guest: Haiku Alpha 3 (vmdk from haiku-r1alpha3-vmdk.zip)

VirtualBox version: 4.0.8

Network Adapter: Intel PRO/1000 MT Desktop (NAT)
listimage (Virtual Haiku's Terminal): /boot/system/add-ons/kernel/drivers/dev/net/ipro1000

Newer (post-r1a3) builds might be affected because of #7750. Didn't try those with VirtualBox.

comment:3 Changed 7 years ago by fano

It's Alpha 3 (hrev42211) and I've no network and the exact same setting of taos Vbox is 4.0.8 in network there is no device e listimage show only 2 libraries relativve at network!

So "not invalid" for me...

comment:4 in reply to:  3 ; Changed 7 years ago by deejam

Replying to fano:

It's Alpha 3 (hrev42211) and I've no network and the exact same setting of taos Vbox is 4.0.8 in network there is no device e listimage show only 2 libraries relativve at network!

So "not invalid" for me...

There are so many people that use Alpha 3 in VirtualBox, and you are the only one that has this issue. Reinstall VirtualBox and Haiku (clean install, no upgrade). If that doesn't work, reinstall your computer.

comment:5 in reply to:  4 ; Changed 7 years ago by Siarzhuk Zharski

Replying to deejam:

Replying to fano:

So "not invalid" for me...

There are so many people that use Alpha 3 in VirtualBox, and you are the only one that has this issue. Reinstall VirtualBox and Haiku (clean install, no upgrade). If that doesn't work, reinstall your computer.

No, fano is the only one that decided to clear the situation and drop the issue in the Trac - but nobody known how many users decided that Haiku is "too raw to try" silently. So the joking about "reinstalling your computer" is unappropriate here. :-(

Replying to fano:

So "not invalid" for me...

Please provide the system log of some boot session. AFAIK, you can configure the VBox virtual machine serial port 1 to be dumped in the text file on host system.

comment:6 Changed 7 years ago by Siarzhuk Zharski

Note that serial debugging should be activated from the boot menu. AFAIR it was disabled for the alpha build for performance.

comment:7 Changed 7 years ago by Fredrik Modéen

Tested now with V-Box 4.0.8 and a downloaded a image (haiku-r1alpha3-vmdk.zip) and I have no problem. A serial debugging would be nice :).. Can you test the same image in vmware? Same driver are used and the vmdk image can be used in both.

comment:8 Changed 7 years ago by taos

It seems serial debugging wasn't disabled by default;-) I only had to activate a serial port (COM1) for the virtual machine, choose the file serial output would be written to and boot virtual haiku. I've added serial output ("haiku-vm_working_ipro1000.txt") of my working configuration to compare with the non-working configuration of fano.

BTW, I've installed the Oracle VM VirtualBox Extension Pack that adds (closed source) support of usb 2.0 and network boot. But that shouldn't matter in regard of fano's issues with ipro1000...

Changed 7 years ago by taos

Serial debugging: working ipro1000

comment:9 in reply to:  5 ; Changed 7 years ago by deejam

Replying to siarzhuk:

No, fano is the only one that decided to clear the situation and drop the issue in the Trac - but nobody known how many users decided that Haiku is "too raw to try" silently.

You could be right, but I think not. The users hasn't been silent on other issues (boot problem, missing wpa support etc).

So the joking about "reinstalling your computer" is unappropriate here. :-(

That was no joke. I was going to ask him to test it on another computer, but realized that it wouldn't exclude VirtualBox as the source of failure (it would probably work). Reinstalling VirtualBox and Haiku (without upgrading) will probably be enough. But if not, it wouldn't prove that the problem really lies in Haiku. Reinstalling the computer – even if it sounds drastic – would.

To sum up: I think the problem is either user handling error (setup of VirtualBox) or a broken Haiku installation (due to upgrade from earlier release). I would be surprised if it is an actual error in Alpha 3.

comment:10 in reply to:  9 Changed 7 years ago by Fredrik Modéen

Replying to deejam:

To sum up: I think the problem is either user handling error (setup of VirtualBox) or a broken Haiku installation (due to upgrade from earlier release). I would be surprised if it is an actual error in Alpha 3.

I have to agree with you on this. The broken commit was never imported in alpha 3 and it's still the 2 year old code (hade a looked in the source). But we will se. Not that we will help out less in that case :)

comment:11 Changed 7 years ago by deejam

fano: I suggest that you attach the dump of VBoxManage showvminfo.

In a terminal, type:

VBoxManage showvminfo name_of_your_virtual_machine

comment:12 Changed 7 years ago by fano

I've tried to deinstall VBOX, clear the register using CCleaner to be safe and reinstalled VBOX... the destroyed my previous Haikuy installation and reinstalled... no network again! VirtualBox indeed is working with the other virtualized system (Ubuntu, CentOs ans Win Xp) has network so not seems a VBOX problem. I, obviously not formatted my host OS -:)))

I've tried VMware Player, too no network again (so no driver is installed)... I've tried the legacy Vlance driver (downloaded from Haikuware) and after a lot of try yesterday network worked and I started to download Haiku SVN but after some hours I noted it was blocked... today network was not working again in VmWare...

Tonight I'll try to obtain serial debugging output and the VBoxManage showvminfo beast.

comment:13 Changed 7 years ago by Siarzhuk Zharski

It can be a good idea to attach the .vbox xml file with settings of your virtual machine too.

comment:14 Changed 6 years ago by diver

Resolution: invalid
Status: newclosed

Most likely a user error after all.

Note: See TracTickets for help on using tickets.