Opened 8 years ago

Closed 8 years ago

#7818 closed bug (fixed)

Debugger has trouble showing useful data

Reported by: pulkomandy Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I used debugger to find a bug in another application, namely APlayer ( http://pulkomandy.lexinfo.fr/projects/APlayer )

I found the following problems :

  • In the file and functions list, I have to click on a function to get the source shown. I expect clicking on a file to also open it, on no particular function (either start of file or where it was last open)
  • After reproducing my bug (the one that was fixed in APlayer's hrev5), I get the backtrace (an assert fail somewhere in Polykit). From there, Imove to the real problem (SidFile::TestIt), but the variables view is empty. At first the source was not found, I had to locate it before I could see it. Maybe that's related ? (variable list not refreshed after source locating ?)

Change History (5)

comment:1 Changed 8 years ago by anevilyak

Component: - GeneralApplications/Debugger
Owner: changed from nobody to anevilyak
Status: newassigned

comment:2 Changed 8 years ago by anevilyak

What is the actual SVN URI for the source tree? I'm unable to find that via the Trac installation you've pointed at, and a few attempts at obvious possibilities have failed so far.

comment:3 Changed 8 years ago by pulkomandy

Sorry. It's svn://pulkomandy.lexinfo.fr/APlayer

No http access.

comment:4 Changed 8 years ago by anevilyak

Status: assignedin-progress

Looks like a problem when parsing the CIE, investigating ...

comment:5 Changed 8 years ago by anevilyak

Resolution: fixed
Status: in-progressclosed

CIE Parsing issue fixed in hrev42434. Please file a separate enhancement ticket for the file/function list request.

Note: See TracTickets for help on using tickets.