Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7829 closed bug (fixed)

Tracker windows pop to front unexpectedly

Reported by: Pete Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In my latest build (hrev42415), I'm finding that Tracker windows behind the currently active one can be brought to the front -- obscuring what I'm working on -- if the mouse happens to stray onto an exposed area of the window while the button is held down. (This typically happens when I'm scrolling the active window, and the cursor accidentally wanders to the right off the scrollbar.)

This seems recently introduced. I don't see it with my alpha-3 USB stick.

Change History (7)

comment:1 Changed 8 years ago by anevilyak

What mouse focus mode and what decorator are you using? I'm not able to reproduce it with the described steps on hrev42419 at least.

comment:2 in reply to:  1 Changed 8 years ago by Pete

Replying to anevilyak:

What mouse focus mode and what decorator are you using? I'm not able to reproduce it with the described steps on hrev42419 at least.

The mode is "Click to focus and raise", and no decorator is enabled (though I did have SAT on for a while). (I note that the mode-selection menu in the Mouse preference is also behaving a bit strangely: If you click to hold it open and then click on the desired option, it doesn't change! You have to drag and release. I tried other preference apps with similar menus, and they all seem to behave as expected -- second-click selects.)

The behaviour is quite consistent [and highly annoying!] on that installation. You do have to hold the mouse on the undesired window for a moment for it to happen. My build does have some variant stuff in libmedia.so, but I've never messed with the Tracker or anything in the display area. The install was overlaid on an earlier one, so I suppose there might be something odd in config/settings?

comment:3 Changed 8 years ago by bonefish

Can reproduce both issues with my package management repository (a bastardized hrev42189, I believe) and FFM. I'd guess both bugs are not related to each other, though. At least one sounds like a Tracker "feature" while the other seems menu related.

comment:4 Changed 8 years ago by anevilyak

Owner: changed from axeld to aldeck
Status: newassigned

Can reproduce it now as well...most likely it's a regression introduced by the rewrite of PoseView's mouse handling.

comment:5 Changed 8 years ago by aldeck

Status: assignedin-progress

Ouch, sounds like my fault! Working on it.

comment:6 Changed 8 years ago by aldeck

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42441 As the problem mentioned in comment 2 seems unrelated, i'm closing this ticket as the orignally reported problem is fixed.

comment:7 in reply to:  6 Changed 8 years ago by Pete

Replying to aldeck:

Fixed in hrev42441

Thanks for the speedy repair! Works now.

As the problem mentioned in comment 2 seems unrelated, i'm closing this ticket as the orignally reported problem is fixed.

Yeah -- I'm sure it's quite separate. Probably shouldn't have mentioned it, as it's hardly serious.

Note: See TracTickets for help on using tickets.