Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7847 closed bug (fixed)

Haiku no longer boots on iMac4,1

Reported by: bobrost Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description

I was unable to boot R1 Alpha 3 on my iMac, though Alpha 1 had previously worked. I've tried a variety of nightly builds to see where the problem started. Alpha 1 is from CD, and the others listed below are all x86gcc2hybrid anyboot images on a USB flash drive.

Hardware:

  • Apple 20-inch iMac (model iMac4,1),
  • Intel Core Duo, 2 cores @ 2 GHz (32-bit only, no 64-bit)
  • 2GB RAM
  • Using rEFIt 0.14 for boot volume selection
  • listdev.txt attached

Releases:

  • alpha1: boots
  • 35928: all boot icons, KDL
  • alpha2: 3 boot icons, hang
  • 37184: boots
  • 38307: 3 boot icons, hang
  • 38563: boots
  • 38969: boots
  • 39173: all boot icons, KDL
  • 39217: boots
  • 40145: reboots before logo splash
  • 40236: reboots before logo splash
  • 41142: reboots before logo splash
  • alpha3: reboots before logo splash
  • 42440: "Divide Error Exception. Welcome to Boot Loader Death Land!"

Attachments (3)

listdev.txt (2.8 KB ) - added by bobrost 10 years ago.
output of listdev
crash.jpg (45.0 KB ) - added by bobrost 10 years ago.
Bootloader crash screen for hrev42440 on iMac4,1
syslog.txt (273.6 KB ) - added by bobrost 10 years ago.
syslog from successful boot on iMac4,1

Download all attachments as: .zip

Change History (10)

by bobrost, 10 years ago

Attachment: listdev.txt added

output of listdev

comment:1 by axeld, 10 years ago

Component: - GeneralSystem/Boot Loader
Owner: changed from nobody to axeld

Can you please attach a photo reproducing the complete error message (including stack trace) that you get with hrev42440?

by bobrost, 10 years ago

Attachment: crash.jpg added

Bootloader crash screen for hrev42440 on iMac4,1

comment:2 by axeld, 10 years ago

Thanks, this seems to be the same issue as #7510. Please retry with hrev42456 or later, and see if that helps.

comment:3 by bobrost, 10 years ago

Confirmed successful boot with hrev42458

comment:4 by axeld, 10 years ago

Great, thanks for the update! Could you please add a syslog of a successful boot for completeness sake (I'm interested in how the EDID dump looks like exactly).

comment:5 by axeld, 10 years ago

Resolution: fixed
Status: newclosed

by bobrost, 10 years ago

Attachment: syslog.txt added

syslog from successful boot on iMac4,1

comment:6 by bobrost, 10 years ago

Added syslog from successful hrev42458 boot, as requested. After today, I will no longer have access to this computer and won't be able to run any more tests for this particular Mac model.

Last edited 10 years ago by bobrost (previous) (diff)

comment:7 by axeld, 10 years ago

Thanks, so there is at least a single valid entry.

Note: See TracTickets for help on using tickets.