Opened 8 years ago

Closed 6 years ago

#7853 closed bug (fixed)

diff command fails on UTF8 characters in file names

Reported by: jonas.kirilla Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/Command Line Tools Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

~/Desktop> ls xxx xxx2
xxx:
ööö

xxx2:
ööö

~/Desktop> find xxx xxx2
xxx
xxx/??????
xxx2
xxx2/??????

~/Desktop> diff -ru xxx xxx2
diff: cannot compare file names `ööö' and `ööö': Invalid Argument

Using R1A3, hrev41667.

Maybe this got fixed with the recent locale-related shell env variable changes?

Change History (4)

comment:1 Changed 8 years ago by diver

#7700 looks related.

comment:2 Changed 6 years ago by stpere

Seems fixed. Kirilla, could you confirm if your use case is still bogus? Thanks!

comment:3 Changed 6 years ago by jonas.kirilla

I can't reproduce it with the latest nightly, so it looks fixed to me. Thanks!

comment:4 Changed 6 years ago by stpere

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.