Opened 7 years ago

Closed 4 months ago

#7856 closed bug (invalid)

Haiku regression, will not boot from usb stick with latest nightlys 42458

Reported by: stargatefan Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: boot usb nightly Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku will not boot with latest nightlys from usb stick. Works from from CD and HDD however. Attaching syslog.

Attachments (1)

syslog (125.1 KB) - added by stargatefan 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by stargatefan

Attachment: syslog added

comment:1 Changed 7 years ago by stargatefan

Component: - GeneralDrivers/USB
Owner: changed from nobody to mmlr

comment:2 Changed 7 years ago by mmlr

This isn't a very helpful bug report. It doesn't seem like USB booting is affected for everyone (which would've been surprising, seeing that there were no obvious recent changes), so I will need a lot more info of your specific problem to do anything. Error messages, logs from an the actually failing USB boot, that kind of thing. Have you tried with different USB sticks? Does the stick work on another OS? Does it still work when you install an older Haiku revision on the same stick? ...

comment:3 in reply to:  2 Changed 7 years ago by stargatefan

Replying to mmlr:

This isn't a very helpful bug report. It doesn't seem like USB booting is affected for everyone (which would've been surprising, seeing that there were no obvious recent changes), so I will need a lot more info of your specific problem to do anything. Error messages, logs from an the actually failing USB boot, that kind of thing. Have you tried with different USB sticks? Does the stick work on another OS? Does it still work when you install an older Haiku revision on the same stick? ...

  1. yes for different usb sticks
  2. tired linux an older revision A3 of haiku, boots fine.

Seems to be effecting 3 machines on my end minimum, all are amd sb6xx and s87xx and sb8xx chipsets. I am not entirely sure its a USB driver problem. I did attach the syslog from the failed boot. It goes all the way to the rocket ICON and just hangs forver, no desktop and machine becomes unresponsive. No HDD activity ot any other activity being indicated

I will snap a screen shot of onscreen debugging. IIRC the last message I observed was something about failing to create some memory adress.

Will report back.

comment:4 Changed 5 years ago by scottmc

Can you recheck this with a newer nightly of Haiku?

comment:5 Changed 3 years ago by DarkmatterVale

Can anyone reproduce this error on the latest builds?

comment:6 Changed 4 months ago by waddlesplash

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.