Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7858 closed bug (fixed)

Missing symbol __12BMailMessage

Reported by: pulkomandy Owned by: czeidler
Priority: normal Milestone: R1
Component: Kits/Mail Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Trying to run the register application from Kagi (http://pulkomandy.lexinfo.fr/~beosarchive/www.emupt.com/beos/k/WORKING/kagi-1.3-x86.zip)

Gt an error message telling I lack 12BMailMessage. Looks like an incompatibility with BeOS ?

Change History (6)

comment:1 Changed 8 years ago by pulkomandy

mh... it's an R4 app so the breakage may not be ours...

comment:2 Changed 8 years ago by pulkomandy

This other app has a similar problem : http://pulkomandy.lexinfo.fr/~beosarchive/archive/nosource/util/desktop/ThinkOfIt_V1_2_x86R4.zip

I'm sure this one used to work in earlier versions of Haiku. This time the missing symbol is AddEnclosure__12BMailMessagePCcPvlb , but I think that's a problem at least in the same C++ class :).

Last edited 8 years ago by pulkomandy (previous) (diff)

comment:4 Changed 8 years ago by czeidler

There is an AddEnclosure which one is exactly missing? http://haiku.it.su.se:8180/source/xref/src/kits/mail/b_mail_message.cpp

comment:5 Changed 8 years ago by czeidler

Resolution: fixed
Status: newclosed

Ah ok opengrok is not up to date. Added the missing class again hope the fixes it.

comment:6 Changed 8 years ago by pulkomandy

They now all work fine, except BeRometer which now has problems with some other symbol. Thanks !

Note: See TracTickets for help on using tickets.