Opened 8 years ago

Closed 3 years ago

#7889 closed bug (fixed)

KDL, possibly FS, possible CDDA related

Reported by: myob Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Ripping a CD via Tracker (copying from CDDA FS), system went to KDL, however I had previously created a directory and was attempting to rename it with that Tracker windows going all white just before this. KDL wrapped around the length of my screen and I didn't capture it

On rebooting and attemping to finish ripping the CD and renaming the directory, another KDL occured (but not instantly) which I did capture a photograph of.

rebooting again and just ripping the last tracks off the CD worked. checkfs shows nothing inconsistant.

As an aside, is there a better way to get the content from KDLs than taking a photo? I've got a USB keyboard which doesn't work in KDL unfortunately.

Attachments (1)

31072011122.jpg (1013.9 KB ) - added by myob 8 years ago.

Download all attachments as: .zip

Change History (8)

by myob, 8 years ago

Attachment: 31072011122.jpg added

comment:1 by myob, 8 years ago

hrev42445, forgot to say

Last edited 8 years ago by axeld (previous) (diff)

comment:2 by axeld, 8 years ago

I've seen those as well when ripping CDs on an older Haiku revision, but had hoped they were gone with hrev41564, but that's apparently not the case, then.

BTW if you prefix the revision with a lowercase 'r', Trac will actually recognize it as revision (I took the liberty to edit your previous comment).

comment:3 by ttcoder, 8 years ago

Cc: degea@… added

comment:4 by mmlr, 8 years ago

I've tried to reproduce this on a machine that actually still has a CD drive and with the few audio CDs I've got. I wasn't able to reproduce the issue however. I've copied 5 different discs starting over with the first one again after this went through. I also tried pushing the memory limit a bit (after getting bored after disc copy 6 or so) by opening a few more apps which got the system unresponsive for a while, but it then recovered and continued on and finished copying just fine. In the end I copied the contents of 8 discs without a crash.

The attached picture shows that the page daemon crashed when running the idle scan, which would indicate that there was no page pressure. Other than that it looks like the cache the page referenced went away or the cache reference of the page has become invalid which would hint at a locking problem.

comment:5 by cian, 7 years ago

Still an issue on A4.1 on the same hardware.

comment:6 by ttcoder, 5 years ago

Any chance hrev48946 fixes this ? The address in the 'suspect' register translates to ascii " sse" (or "ess " with little-endian conventions) ...

comment:7 by axeld, 3 years ago

Resolution: fixed
Status: newclosed

Yes, that should indeed have fixed it. If not, please reopen with a new KDL report.

Note: See TracTickets for help on using tickets.