Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#7917 closed enhancement (invalid)

Make the exported RDEF header more useful

Reported by: mmadia Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/Icon-O-Matic Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

This patch changes the rdef header to one that can be used by Haiku's build system. AFAICT, the current header is broken -- due the opening curly brace occuring within the comment -- resource(<your resource id here>) #'VICN' array {

Attachments (1)

icon-o-matic_rdef-header.patch (572 bytes) - added by mmadia 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by mmadia

comment:1 Changed 6 years ago by mmadia

Has a Patch: set

comment:2 Changed 4 years ago by waddlesplash

LGTM. Anyone see a reason not to apply this?

comment:3 Changed 4 years ago by waddlesplash

Resolution: invalid
Status: newclosed

Invalid, according to Stephan on IRC.

comment:4 Changed 4 years ago by pulkomandy

And here is why it is invalid:

  • #'VICN' is the same as vector_icon. We could use the latter for better readability, maybe
  • The # is not starting a comment, but the tag for a raw 4 character type
  • You do need to set a resource ID, and the patch wrongly remove that part

comment:5 Changed 4 years ago by stippi

A bit differently. The export from I-O-M is supposed to let you define your own resource ID (and help you with the rdef syntax). "vector_icon" is a shortcut that was added later to rc (?) and it not only sets the array type (#'VICN'), but also the resource ID to one that is reserved for file icons (IIRC). And that is what I don't like about the patch.

Also, I don't understand why there is any problem in the first place. I use this declaration for example in the HaikuDepot rdef file, and there are no problems, are there?

http://cgit.haiku-os.org/haiku/tree/src/apps/haikudepot/HaikuDepot.rdef

comment:6 Changed 4 years ago by stippi

... maybe someone forgot to actually change the "<your resource id here>" part for an actual ID and thought the syntax is broken?

Note: See TracTickets for help on using tickets.