Opened 8 years ago

Closed 8 years ago

#8046 closed bug (duplicate)

KDL with Radeon HD 4250 IGP (AMD 880G chipset)

Reported by: polari Owned by: kallisti5
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: #8040 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku KDLs upon reaching the last icon on the boot screen since the radeon_hd driver was included in the image. Radeon HD 4250 IGP (AMD 880G chipset) with hrev42896. I have included a photo of the KDL with bt, let me know if there's any other information I can provide that will assist you. Thanks. :)

Attachments (1)

DSC_0008.jpg (999.2 KB ) - added by polari 8 years ago.
KDL screen

Download all attachments as: .zip

Change History (2)

by polari, 8 years ago

Attachment: DSC_0008.jpg added

KDL screen

comment:1 by kallisti5, 8 years ago

Keywords: #8040 added
Resolution: duplicate
Status: newclosed

Thanks for the feedback. This is the same issue as #8040

IGP chipsets require a special call to pull the AtomBIOS.

This isn't a KDL but the app_server crashing due to the radeon_hd accelerant bailing out. I wish there was a way to fall back to VESA when the accelerant has a failure.

/* If you boot an IGP board with a discrete card as the primary,
 * the IGP rom is not accessible via the rom bar as the IGP rom is
 * part of the system bios.  On boot, the system bios puts a
 * copy of the igp rom at the start of vram if a discrete card is
 * present.
 */
Note: See TracTickets for help on using tickets.