Opened 8 years ago

Closed 8 years ago

#8058 closed bug (fixed)

Haiku Won't boot on Acer Veriton 9100

Reported by: Giova84 Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha3
Keywords: PMA Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Haiku Won't boot on Acer Veriton 9100 (this computer in anyway was upgraded by myself)

here the specs:

Intel P4 Willamette, 1.4GHz
System Chipset Intel 850 (Tehama)
256 MB RDRAM (rambus)
Videocard Geforce 4 MX 440-SE
Soundboard Embedded AC 97 (recognized as "Intel audiocard", inside Windows XP)
Ethernet Intel ICH2 10/100
HDD: 30 GB ATA 100.

When i insert the LIVE CD (i've tried with Alpha 3 and with the last nightly build) it hangs to the the last icon (the rocket). With "on screen debug" i can see these error message:

PMA: found no free slot to store 64 bytes

PMA: found no free slot to store 32 bytes
(These messages are repeated many times)

After this, the startup process hangs. No resolution with all combination of startup options via spacebar.

Change History (12)

comment:1 Changed 8 years ago by mmlr

Owner: changed from nobody to mmlr
Status: newassigned

Interesting. This indicates that the physical memory pool of the USB stack runs full. What kind of USB devices do you have attached to this system? You say you used alpha 3, but also a nightly, which one is it?

comment:2 Changed 8 years ago by mmlr

Component: - GeneralDrivers/USB
Keywords: PMA added; boot trouble hangs acer veriton removed

comment:3 in reply to:  1 Changed 8 years ago by Giova84

Replying to mmlr:

Interesting. This indicates that the physical memory pool of the USB stack runs full. What kind of USB devices do you have attached to this system? You say you used alpha 3, but also a nightly, which one is it?

Hi, mmlr.

To the system there is no USB device connected.. When i boot-up Haiku, all USB ports are free.

The nighlty is hrev42930.

comment:4 Changed 8 years ago by Giova84

Uhm.. That's very strange. Now Haiku (Alpha 3 and hrev42930) startup fine if i only select "safe mode". Till yesterday the safe mode did not work.

Then, when the desktop appears, Deskbar is blocked.. And no one app or preference start properly (nothing happen) I look for the syslog but the "log" folder is empty. And for shutdown or reboot i have to press the power button on computer, because the task manager hangs too.

comment:5 Changed 8 years ago by Giova84

Another update: I have installed Haiku on the hard disk. it startup and work fine (but still only in safe mode), and i no longer get the error about PMA.

In safe mode some Haiku's servers doesn't start (debug server, the media servers, mount server and net server). So, inside the safe mode i've tried to start manually those servers.. All starts fine.. When i tried to start the net_server, Haiku freeze! So, i edited the BootScript excluding the net_server from startup. Now Haiku boot-up in normal mode. So the net_server is guilty!

comment:6 Changed 8 years ago by mmlr

Possibly the PMA errors are now at least different in hrev43125, but most probably there's something else going on that merely causes enough delays for the USB code come to a halt (an interrupt storm most likely). You mentioned the starting the net_server causes the issue, so it's possible that the network card driver is to blame here.

comment:7 Changed 8 years ago by Giova84

I no longer got the errors about PMA. I can confirm that net_server cause the issue on my PC.

But if i boot Haiku in the safe mode, i cannot obtain the syslog! (in normal mode the net_server cause system's hang). What can i do to help in the ticket's solving?

comment:8 Changed 8 years ago by Giova84

Maybe, the ticket's properties should be changed, considering the net_server issue? Or i should open a new ticket?

comment:9 Changed 8 years ago by Giova84

Another update here: with the last available nightly build (hrev43152) the issue is gone. I took the "ipro100" driver and the net_server from this build and i put them inside Alpha3. Now Haiku boot-up without hangs, with net_server started.

comment:10 in reply to:  9 Changed 8 years ago by mmlr

Replying to Giova84:

Another update here: with the last available nightly build (hrev43152) the issue is gone. I took the "ipro100" driver and the net_server from this build and i put them inside Alpha3. Now Haiku boot-up without hangs, with net_server started.

That's "interesting" to say the least, as there have been no changes to either the net_server nor the ipro100 driver between the mentioned nightlies. However my PMA changes would only actually end up in the newest nightly hrev43152. That you can't get a syslog in safemode is caused by the syslog_daemon not running under safemode (which should probably be changed), so it's expected.

comment:11 Changed 8 years ago by Giova84

With the latest nightly builds (since hrev43152) the issue seems gone.

comment:12 Changed 8 years ago by mmlr

Resolution: fixed
Status: assignedclosed

Thanks for the update. Fixed in hrev43125.

Note: See TracTickets for help on using tickets.