Opened 6 years ago

Closed 6 years ago

#8091 closed bug (fixed)

[Debugger] crashes in n BSplitLayout::_ValidateMinMax ()

Reported by: diver Owned by: Rene Gollent
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8099
Has a Patch: yes Platform: All

Description

This is hrev43191, gcc2hybrid.

Don't know how to reproduce it yet.

Thread 5381 caused an exception: Segment violation
[...]
[Switching to team /boot/system/apps/Debugger (5351) thread w>/boot/system/apps/StyledEdit  (5381)]
0x005a838f in BSplitLayout::_ValidateMinMax () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x005a838f in BSplitLayout::_ValidateMinMax () from /boot/system/lib/libbe.so
#1  0x005a60cc in BSplitLayout::BaseMinSize () from /boot/system/lib/libbe.so
#2  0x0052639b in BAbstractLayout::MinSize () from /boot/system/lib/libbe.so
#3  0x005c7813 in BTwoDimensionalLayout::LocalLayouter::AddConstraints () from /boot/system/lib/libbe.so
#4  0x005c67a1 in BTwoDimensionalLayout::CompoundLayouter::_AddConstraints () from /boot/system/lib/libbe.so
#5  0x005c650f in BTwoDimensionalLayout::CompoundLayouter::ValidateMinMax () from /boot/system/lib/libbe.so
#6  0x005c7382 in BTwoDimensionalLayout::LocalLayouter::ValidateMinMax () from /boot/system/lib/libbe.so
#7  0x005c6099 in BTwoDimensionalLayout::_ValidateMinMax () from /boot/system/lib/libbe.so
#8  0x005c5794 in BTwoDimensionalLayout::BaseMinSize () from /boot/system/lib/libbe.so
#9  0x0052639b in BAbstractLayout::MinSize () from /boot/system/lib/libbe.so
#10 0x005d2332 in BView::MinSize () from /boot/system/lib/libbe.so
#11 0x005da10f in BWindow::UpdateSizeLimits () from /boot/system/lib/libbe.so
#12 0x005dc908 in BWindow::Layout () from /boot/system/lib/libbe.so
#13 0x005d9c5a in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#14 0x00304a46 in TeamWindow::DispatchMessage ()
#15 0x005de06c in BWindow::task_looper () from /boot/system/lib/libbe.so
#16 0x005093df in BLooper::_task0_ () from /boot/system/lib/libbe.so
#17 0x0091395f in thread_entry () from /boot/system/lib/libroot.so
#18 0x7823bfec in ?? ()
(gdb)

Attachments (1)

TeamWindow.patch (584 bytes) - added by Rene Gollent 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 6 years ago by Rene Gollent

I suspect I know why....can you confirm that this occurred when it was first opening the debugger window, and not just randomly at runtime?

comment:2 Changed 6 years ago by Rene Gollent

Status: newin-progress

comment:3 Changed 6 years ago by diver

It happens after opening debugger window, changing vertical splitter position, closing debugger and reopening again.

comment:4 Changed 6 years ago by Rene Gollent

Thus far I've been completely unable to reproduce the problem, even with those steps. Can you by any chance attach the output of thread apply all bt when it happens for you?

Changed 6 years ago by Rene Gollent

Attachment: TeamWindow.patch added

comment:5 Changed 6 years ago by Rene Gollent

Has a Patch: set

comment:6 Changed 6 years ago by Rene Gollent

Also, please try if applying TeamWindow.patch makes any difference.

comment:7 Changed 6 years ago by Rene Gollent

Blocking: 8099 added

(In #8099) Duplicate of #8091. Should have a fix ready later today.

comment:8 Changed 6 years ago by Rene Gollent

Fixed in hrev43206.

comment:9 Changed 6 years ago by Rene Gollent

Resolution: fixed
Status: in-progressclosed
Note: See TracTickets for help on using tickets.