Opened 8 years ago

Closed 8 years ago

#8095 closed bug (fixed)

Source file path resolution doesn't work as is should

Reported by: bonefish Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications/Debugger Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev43130, gcc 2, Haiku image cross-built on Linux

The intelligent source file path resolution doesn't work as expected. After specifying the path to the first source file, the paths for other source files should be guessed automatically, if their location relative to the first source file has not changed (i.e. is the same as when compiled).

Tested debugging DebugAnalyzer, source copied to the image via the AddSourceDirectoryToHaikuImage rule. The DebugAnalyzer.cpp source file was specified after starting Debugger before running the program. A later crash in model_loader/ModelLoader.cpp did not show the source file and the file had to be specified manually as well.

Change History (7)

comment:1 Changed 8 years ago by anevilyak

Owner: changed from bonefish to anevilyak
Status: newassigned

comment:2 Changed 8 years ago by anevilyak

Will dig into this, since I had to make changes to the source file resolution code to get it to work at all when I exposed that functionality via the UI, it's possible I broke some aspect of it. Out of curiosity, were the source paths in the DWARF info absolute or relative with the binary you had?

comment:3 Changed 8 years ago by anevilyak

Status: assignedin-progress

Never mind, can reproduce it. Looking...

comment:4 Changed 8 years ago by anevilyak

Status: in-progressassigned

Problem found: LocatableDirectory::AddEntry() is never actually called, thus when FileManager::_LocateEntries() tries to traverse and update every similar file, the directories have no entries to update and the function returns immediately without doing anything. At the moment I'm not yet certain as to the correct place to add that call though, and I'm out of time for tonight.

If you remember more clearly and can easily fix it, feel free, otherwise I'll try to grok the structure of the file manager a bit better sometime this week so I can fix it myself.

comment:5 Changed 8 years ago by bonefish

I can't say I recall the details of the file manager code. You're probably already at least as familiar with the code as I am. Although a bit annoying (particularly since the file dialog doesn't remember its directory) it isn't high priority either.

comment:6 Changed 8 years ago by anevilyak

Status: assignedin-progress

comment:7 Changed 8 years ago by anevilyak

Resolution: fixed
Status: in-progressclosed

Intelligent location fixed, and file panel modified to remember its last location in hrev43263.

Last edited 8 years ago by anevilyak (previous) (diff)
Note: See TracTickets for help on using tickets.