Opened 8 years ago

Closed 7 years ago

#8144 closed bug (invalid)

WebPositive downloads CSS files instead of just rendering

Reported by: tidux Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: CSS Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I'm on hrev43238, and WebPositive is, for some reason, downloading copies of the CSS files from certain websites. It's using them to render properly, but it downloads a copy of each CSS file present to /boot/home/Desktop, which is irritating since it immediately clutters up the desktop. Maybe it was supposed to output to /tmp? At any rate, this is reproducible on any of the boards on 4chan.org.

Change History (3)

comment:1 Changed 7 years ago by tidux

Well, I don't know what changed, but I'm no longer seeing this in hrev43728. Mark as closed?

comment:2 Changed 7 years ago by leavengood

It could be that 4chan.org just fixed their CSS. I don't recall if I ever tried to test this, but if the web server was reporting the MIME type of the CSS files as something that wasn't CSS, Web+ might just try to download them. This of course isn't right, but in general browsers try to trust the web servers.

My Haiku development time is basically nil right now, but I'll try to look at this next time I'm working on Web+, so I will leave it open.

If you find any other sites where this happens, let me know. Worse case I could make a test web server to see if my suspicions are correct about the MIME types.

comment:3 Changed 7 years ago by aldeck

Resolution: invalid
Status: newclosed

Never seen this issue and can't reproduce with the current Web+, closing.

Note: See TracTickets for help on using tickets.