Opened 8 years ago

Closed 5 years ago

#8161 closed bug (fixed)

[Tracker] crash in Open with window

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev43324, gcc2hybrid.

Don't know how to reproduce it yet.

vm_soft_fault: va 0x5f505000 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x5f505574, ip 0x2dcda3, write 0, user 1, thread 0xf1
vm_page_fault: thread "add poses" (241) in team "Tracker" (104) tried to read address 0x5f505574, ip 0x2dcda3 ("libbe.so_seg0ro" +0xdada3)
debug_server: Thread 241 entered the debugger: Segment violation
stack trace, current PC 0x2dcda3  _FindField__C8BMessagePCcUlPPQ28BMessage12field_header + 0x3b:
  (0x781fa67c)  0x2dd4dd  FindData__C8BMessagePCcUllPPCvPl + 0x4d
  (0x781fa6bc)  0x2e0627  FindRef__C8BMessagePCclP9entry_ref + 0x57
  (0x781fa71c)  0x5d9710  Relation__Q28BPrivate27SearchForSignatureEntryListPC8BMessagePCQ28BPrivate5ModelPC9entry_refT3 + 0x48
  (0x781fa7fc)  0x5da150  CanOpenWithFilter__Q28BPrivate27SearchForSignatureEntryListPCQ28BPrivate5ModelPC8BMessagePC9entry_ref + 0x23c
  (0x781faa2c)  0x5d7e0f  ShouldShowPose__Q28BPrivate16OpenWithPoseViewPCQ28BPrivate5ModelPCQ28BPrivate8PoseInfo + 0x53
  (0x781faa5c)  0x5e329f  AddPosesTask__Q28BPrivate9BPoseViewPv + 0x667
  (0x781fafac)  0x70cc47  thread_entry + 0x23

Change History (2)

comment:1 by waddlesplash, 5 years ago

Any updates?

comment:2 by diver, 5 years ago

Resolution: fixed
Status: newclosed

Haven't seen it since then. Hopefully fixed in the meantime.

Note: See TracTickets for help on using tickets.