Opened 8 years ago

Closed 8 years ago

#8184 closed bug (invalid)

Deskbar use 829.38 MiB of ram

Reported by: Giova84 Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

As you can see in the screenshot, Deskbar is using 829.39 MiB of ram.. I don't know why!

hrev43375

Attachments (3)

Deskbar_Ram.png (67.3 KB) - added by Giova84 8 years ago.
Deskbar_Ram2.png (60.3 KB) - added by Giova84 8 years ago.
listarea.txt (159.8 KB) - added by Giova84 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by Giova84

Attachment: Deskbar_Ram.png added

comment:1 Changed 8 years ago by Giova84

Now amount of RAM used by Deskbar is 1019.22 MiB.. This is really a bug! Is very strange.. I'm not using any kind of strange application.. Look the screenshot Deskbar_Ram2.png

Changed 8 years ago by Giova84

Attachment: Deskbar_Ram2.png added

comment:2 Changed 8 years ago by bonefish

Keywords: deskbar using too much ram removed
Version: R1/alpha3R1/Development

Please attach the output of listarea.

Changed 8 years ago by Giova84

Attachment: listarea.txt added

comment:3 Changed 8 years ago by Giova84

Output of listarea attached.

comment:4 Changed 8 years ago by bonefish

Thanks. It's a heap leak. What Deskbar replicants are you using?

comment:5 Changed 8 years ago by Giova84

Process Controller, Network Status, MinimizeAll and sometimes XVideoServiceThief. To bring Deskbar in normal consumption of ram i have to quit it and restart.

comment:6 Changed 8 years ago by bonefish

I'm asking about the replicants, because Deskbar itself hasn't really changed recently. Was XVideoServiceThief running? Can you reproduce the issue? If you can, how? And can you verify whether any of the replicants is responsible?

comment:7 Changed 8 years ago by Giova84

XVideoServiceThief is this QT app: http://haikuware.com/directory/view-details/internet-network/clients/xvideoservicethief-24

This application grabs flash videos from various websites and when is started, install a replicant inside the Deskbar. From this screenshot: https://dev.haiku-os.org/attachment/ticket/8184/Deskbar_Ram.png you can see in process list (xvst). When it download files, Xvst increase his ram consumption.. And inside Process Controller i can see that Deskbar's ram consumption is going higher too, only when xvst is started.. So i can tell that Xvst is the guilty!

Why this happens?

comment:8 in reply to:  7 Changed 8 years ago by bonefish

Resolution: invalid
Status: newclosed

Replying to Giova84:

So i can tell that Xvst is the guilty!

Why this happens?

Apparently the replicant has a memory leak. Please report that to the author.

Note: See TracTickets for help on using tickets.