Opened 8 years ago

Last modified 10 months ago

#8232 new bug

MCP89 chipset recognized, but no sound

Reported by: Dilbert2 Owned by: korli
Priority: normal Milestone: R1/beta2
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: soundcard, Mac, Macbook Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hello. I have bought a second hand 13" Macbook Pro. Intel Core Duo, 4GB RAM, 2 USB ports. It works perfectly in Mac OSX Lion, so this is not a hardware issue.

I want to use Haiku on this Mac. Booting macs from memory stick is really complicated, (or so I'm told,) so I boot it from a CD.

I burn the R1A3 iso file to disc, put it into my Mac, and hold button "c" while it boots. Screen turns black and Haiku logo appears on the Mac. The seven grey icons below the Haiku logo also appear.

Here's the first problem: Sometimes the seven grey icons just stay grey, and nothing more happens. If this happens, I just reboot and try again. Sometimes all seven icons get color, and Haiku loads. It asks about keymap and language. I click on Live CD, not Installer.

Here's the second problem. I use a USB mouse.

The Mac's trackpad and keyboard show no sign of working at all.

My USB mouse (Logitech Unifying wireless) is my only input device. Also, my Unifying USB keyboard does not work in Haiku on this Mac. So, I have no keys at all. The USB mouse works sometimes. The last time I booted it, it worked for a few minutes, then stopped working, then it worked again, then it stopped working...........

So, external USB mouse works good sometimes, but not always. Internal touchpad never works. Internal and external USB keyboard never works.

Also, it does not care about memory sticks being inserted. No icon appears. I know Haiku supports memory sticks, but it does not work on this Mac.

And there is no network access, so I can't transfer syslog. I took a photo of syslog, but it's very long, and a picture can't contain everything.

Deskbar identifies my network card as /dev/net/broadcom570x/0 It says Configuring and then Ready when plugged in, and No link when unplugged. It knows when the network cable is connected, but does not work. WebPositive says "Can't resolve hostname" if I click on any of the links in the Welcome page.

Also, if I click on the sound icon, It says "Could not find the mixer".

So, no keyboard, no touchpad, no sound, sometimes USB mouse (it may work for a few minutes, then stop for a while, then resume working.....), no memory stick, no network connection (although it knows when the cable is inserted, and I know that cable works)...

Attachments (2)

10122011082.jpg (4.3 MB ) - added by Dilbert2 8 years ago.
photo of syslog
FW4h89Jm.txt (193.0 KB ) - added by diver 7 years ago.
syslog

Change History (10)

by Dilbert2, 8 years ago

Attachment: 10122011082.jpg added

photo of syslog

comment:1 by Dilbert2, 8 years ago

New info I burnt the latest Anyboot Image (43447) to a DVD (previously I used R1A3 iso) and booted the Mac from it.

It works MUCH better now.

Touchpad works Keyboard works (internal works. I haven't tested external) Network (wired) works USB mouse works Sound pretends to work. MP3 files seem to play, but there's no sound. Volume control works, but there is no sound. USB memory stick works.

Still no wireless network. But this is progress :-)

comment:2 by luroh, 8 years ago

So, we'd need a 'listdev' to find out what sound chipset that computer has. A syslog probably wouldn't hurt either.

comment:3 by Dilbert2, 8 years ago

Here is syslog on pastebin (posting from the Haiku mac) http://pastebin.com/FW4h89Jm

I have been on IRC. Here is parts from a IRC conversation:

	mmlr_thinkpad	Per_Vers: the wireless chip is a bcm4322, which our bwi driver doesn't yet support
	mmlr_thinkpad	it supports up to and including 431a only
	Per_Vers	Will it be supported?
	mmlr_thinkpad	a newer version of the bwi driver will need to be ported to get support for that

	Per_Vers	But I still have sound problems.
	mmlr_thinkpad	yes, it seems that most current hda devices fail with our driver
	mmlr_thinkpad	so that's not too surprising
	Per_Vers	Sound appears to work. mp3-files play, and I can slide the volume control. But it's quiet.
	mmlr_thinkpad	yes
	mmlr_thinkpad	it's a common problem (...) it's our hda driver (...)
Last edited 8 years ago by mmlr (previous) (diff)

comment:4 by modeenf, 7 years ago

Looks like FreeBSD don't have support ether for bcm4322.

http://lists.freebsd.org/pipermail/freebsd-net/2011-January/027717.html

So this will not be supported here anytime soon.

by diver, 7 years ago

Attachment: FW4h89Jm.txt added

syslog

comment:5 by diver, 7 years ago

vendor 10de: nVidia Corporation
device 0d94: MCP89 High Definition Audio

comment:6 by diver, 7 years ago

Component: Drivers/USBDrivers/Audio/HDA
Keywords: Keyboard mouse network touchpad removed
Owner: changed from mmlr to korli
Version: R1/alpha3R1/Development

comment:7 by diver, 7 years ago

Summary: MacBook Pro, mouse, keyboard, sound and network fails.MCP89 chipset recognized, but no sound

comment:8 by pulkomandy, 10 months ago

Milestone: R1R1/beta2
Note: See TracTickets for help on using tickets.