Opened 8 years ago

Closed 8 years ago

#8245 closed bug (fixed)

mail_daemon crashing notification_server

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1
Component: Servers/notification_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev43515.

In my quest to fetch mail with the mail_daemon, I updated to the latest revision. Fetching mail with activated notifications crashes the notification_server with this backtrace:

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 822 called debugger(): Trying to delete a view that belongs to a window. Call RemoveSelf first.
[...]
[Switching to team /boot/system/servers/notification_server (818) thread w>Notification (822)]
0xffff0114 in ?? ()
(gdb) bt
#0  0xffff0114 in ?? ()
#1  0x00594f66 in debugger () from /boot/system/lib/libroot.so
#2  0x003b59ba in BView::~BView () from /boot/system/lib/libbe.so
#3  0x0020d1f9 in NotificationView::~NotificationView ()
#4  0x0020bed3 in AppGroupView::AddInfo ()
#5  0x0021051f in NotificationWindow::MessageReceived ()
#6  0x002f3f9b in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#7  0x003c5d59 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#8  0x003ca0e0 in BWindow::task_looper () from /boot/system/lib/libbe.so
#9  0x002f54b7 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#10 0x005998a7 in thread_entry () from /boot/system/lib/libroot.so
#11 0x78033fec in ?? ()
(gdb) 

Calling notify "Test" from Terminal works.

Change History (1)

comment:1 by humdinger, 8 years ago

Resolution: fixed
Status: newclosed

Cannot reproduce anymore with hrev43630. Maybe it was some glitch in my setup... might not be "fixed" but "invalid", who knows.

Note: See TracTickets for help on using tickets.