Opened 8 years ago

Closed 5 months ago

#8285 closed bug (invalid)

No keyboard & mouse in Hyper-V Haiku VM

Reported by: Mictlantecuhtli Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Input/PS2/Keyboard Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Keyboard & mouse don't work in Haiku virtual machine (hrev43663). Host is Windows Server 2008 R2 SP1 Enterprise Edition, Haiku settings seen in attached image. There aren't any keyboard/mouse related settings in the host (as far as I can tell).

Last lines from attached syslog:

ps2: keyboard reset failed, status 0x80000009, data 0x00
ps2: keyboard probing failed
ps2: devfs_unpublish_device input/keyboard/at/0, status = 0x00000000
KeyboardDevice: error when opening /dev/input/keyboard/at/0: No error
ps2: cannot enable mouse input/mouse/ps2/ibm_trackpoint_0

Attachments (3)

putty.log (38.0 KB ) - added by Mictlantecuhtli 8 years ago.
syslog
vhaiku.png (58.7 KB ) - added by Mictlantecuhtli 8 years ago.
Haiku settings in Hyper-V Manager
vcom1.log (43.7 KB ) - added by siarzhuk 8 years ago.
Haiku log acquired under Hyper-V with etended ps2 tracing.

Download all attachments as: .zip

Change History (9)

by Mictlantecuhtli, 8 years ago

Attachment: putty.log added

syslog

by Mictlantecuhtli, 8 years ago

Attachment: vhaiku.png added

Haiku settings in Hyper-V Manager

by siarzhuk, 8 years ago

Attachment: vcom1.log added

Haiku log acquired under Hyper-V with etended ps2 tracing.

comment:1 by siarzhuk, 8 years ago

Finally I have set this system up and acquired more extended tracing of the boot. :-)

1) Have you successfully boot from the virtual drive or from CD image? I have run into the "Cannot mount boot partition" error with the VHD image I have converted by VBox-Img from the RAW haiku image.

2) How do you setup the network connection? On my system it says "No connection" in the corresponding pane of the VM settings. In the system log I see that ethernet hardware is emulated, but how to configure it. Hm...

PCI: [dom 0, bus  0] bus   0, device 10, function  0: vendor 1011, device 0009, revision 20
PCI:   class_base 02, class_function 00, class_api 00
PCI:   vendor 1011: Digital Equipment Corporation
PCI:   device 0009: DECchip 21140 [FasterNet]
PCI:   info: Network controller (Ethernet controller)

in reply to:  1 comment:2 by Mictlantecuhtli, 8 years ago

Replying to siarzhuk:

1) Have you successfully boot from the virtual drive or from CD image? I have run into the "Cannot mount boot partition" error with the VHD image I have converted by VBox-Img from the RAW haiku image.

I downloaded an anyboot image, renamed to .iso and booted with it as CD.

2) How do you setup the network connection? On my system it says "No connection" in the corresponding pane of the VM settings. In the system log I see that ethernet hardware is emulated, but how to configure it. Hm...

I'll have to check later, I'm not at home right now. There's no network adapter in my log though.

comment:3 by siarzhuk, 5 years ago

Owner: changed from siarzhuk to nobody
Status: newassigned

For years I was default assignee for this PS2 stuff. Neither fixes nor improvements - I should be fired away. ;-)

comment:4 by modeenf, 3 years ago

Perhaps we can close this? don't know any Hyper-V system that uses PS2 these days?

If nothing else, it's working perfectly with Windows 10 as host OS and USB mouse and keyboard.

comment:5 by waddlesplash, 9 months ago

Component: Drivers/Keyboard/PS2Drivers/Input/PS2/Keyboard

comment:6 by waddlesplash, 5 months ago

Resolution: invalid
Status: assignedclosed
Note: See TracTickets for help on using tickets.