Opened 13 years ago

Closed 13 years ago

#829 closed bug (fixed)

Mouse and keyboard fail to work if USB legacy mouse support is activated

Reported by: nielx Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Mouse Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

A problem mentioned on the mailing list (http://www.freelists.org/archives/openbeos/08-2006/msg00574.html), I can't seem to think that mine is related.

Mouse input and keyboard input only work in rare exceptions (the mails mention 1 in 20, but that seems like a random number). The system is not frozen, since the clock keeps running. I discovered that when I disable USB legacy mouse support in my BIOS, there are no issues and both mouse and keyboard works (even though keyboard legacy support is enabled).

The type of hardware (PS2 or USB) doesn't matter, it works with neither.

I've attached a syslog.

Attachments (1)

syslog (38.1 KB) - added by nielx 13 years ago.
Syslog

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by nielx

Attachment: syslog added

Syslog

comment:1 Changed 13 years ago by marcusoverhagen

Resolution: fixed
Status: newclosed

Fixed in release 18677.

comment:2 Changed 13 years ago by nielx

Resolution: fixed
Status: closedreopened

Unfortunately, it's not. Perhaps it has something to do with the USB legacy emulation. I don't know exactly how it works, but I imagine that the BIOs presents another PS2 interface. Perhaps it fails because the driver fails to open the actual PS2 controller.

If you need a new syslog, please ask.

comment:3 Changed 13 years ago by marcusoverhagen

The bug shown in the original syslog should be fixed. Please provide a new one, with release 18694 or above.

comment:4 Changed 13 years ago by wkornewald

Milestone: R1
Version: R1 development

comment:5 Changed 13 years ago by nielx

Resolution: fixed
Status: reopenedclosed

With the current revisions (around 18900) it seems to be resolved.

Strange, all my problems seem to go away.

Thanks!

Note: See TracTickets for help on using tickets.