Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#8307 closed bug (no change required)

Intel Pentium II 266 System uses 100% CPU w/ USB mouse use

Reported by: Luposian Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

But it only uses about 26-27% CPU usage (6 bars lit, out of 20, in Pulse), using a PS/2 mouse. Is older technology simply being phased out and ignored, thus losing support? The system also bogs and gets "stodgy" (stubborn and unresponsive; i.e. 100% CPU usage frequently) in other areas as well.

I don't believe BeOS R5 PE would behave this way on this same hardware. I can test, to check.

Motherboard: Intel, CPU: Intel Pentium II (266MHz), Chipset: Intel 440BX, RAM: 384Mb (PC100), Hard Drive: 9Gbyte IDE (40-pin cable), Video card: AGP nVidia GeForce 2 (Ultra)

Change History (6)

comment:1 by jonas.kirilla, 8 years ago

It's likely an effect of the accelerated drawing functions not being used currently. Additionally the cursor isn't a hardware cursor and thus causing redraws as you move it around. IIRC Haiku works better on more recent hardware with the app_server changes that prompted the turning off of the accelerant functions, and the drawbacks on older hardware was deemed as no big loss at the time. (Was it double-buffering?)

There was a discussion on it, which I haven't found, but maybe this will get you started: http://www.freelists.org/post/haiku-development/AppServer-and-Video-Driver-Question

comment:2 by axeld, 8 years ago

In fact it would be quite nice if the app_server would determine it's running mode depending on the hardware it runs on - at runtime. Patches welcome :-)

comment:3 by Luposian, 8 years ago

I've just dismantled my PII system. I'm going to try to sell what I can from it and throw the rest away. It's just too old to be worthwhile to bother with anymore. So, you can close this ticket, if you want.

comment:4 by Luposian, 6 years ago

Please close this ticket. I no longer have this system and I doubt anyone else cares to run Haiku on an old PII system, anyways.

comment:5 by korli, 6 years ago

Resolution: no change required
Status: newclosed

comment:6 by cb88, 6 years ago

For what it is worth I have a dual PII system still with 512Mb ram... I'll reopen the ticket if I get a chance to work on it (I'll be sending it off for a recap soon). I have no intention of getting rid of it.. and as you said it would nice to auto detect the mode the App server runs in.

It has a radeon 9800 Pro SE in it... so it might actually have an accelerant though and I don't think my Geforce 2 MX 400 will fit in that system as its AGP 1/2 only besides the radeon is already WAAAY overkill.

In any case BeOS would have been quite snappy on this hardware. It would be nice it reclaim some of that though some of the losses are probably performance wins on newer systems.

Note: See TracTickets for help on using tickets.