Opened 8 years ago

Closed 3 years ago

#8326 closed bug (duplicate)

kernel crashed while deleting a file

Reported by: bharath_a0 Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/alpha3
Keywords: Cc:
Blocked By: #4756 Blocking:
Has a Patch: no Platform: x86

Description

While trying to delete a file from desktop the kernel crashed, below is the snapshot of the kernel crash

Attachments (1)

Selection_001.png (71.1 KB) - added by bharath_a0 8 years ago.
kernel crash snapshot

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by bharath_a0

Attachment: Selection_001.png added

kernel crash snapshot

comment:1 Changed 8 years ago by anevilyak

Component: File SystemsFile Systems/BFS
Owner: changed from nobody to axeld
Status: newassigned

Possibly a duplicate of #4756.

comment:2 in reply to:  1 ; Changed 8 years ago by HaikuReactOSTrac

Replying to anevilyak:

Possibly a duplicate of #4756.

These two issues don't look like duplicates to me, because the panic in #4756 occurs right after boot, and the panic in this issue occurs while trying to delete a file. Also, I could not reproduce this issue (also using R1/Alpha 3).

comment:3 in reply to:  2 Changed 8 years ago by anevilyak

Replying to HaikuReactOSTrac:

These two issues don't look like duplicates to me, because the panic in #4756 occurs right after boot, and the panic in this issue occurs while trying to delete a file. Also, I could not reproduce this issue (also using R1/Alpha 3).

The timing isn't really all that relevant. The fact that a transaction is involved hints that both cases involve writes, and furthermore, similar code paths in BFS are being hit, which hints that the underlying problem may be the same. In any case, I've never seen this one in 5-6 years of running Haiku across various revisions either. I'll leave it to Axel to decide on whether it's a duplicate or not for certain.

comment:4 Changed 3 years ago by axeld

Blocked By: 4756 added
Resolution: duplicate
Status: assignedclosed

Yep, seems to be the same issue as #4756; of course, it might be caused by a different issue, but that's impossible to tell from the available info.

Note: See TracTickets for help on using tickets.