Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#8331 closed bug (fixed)

Garbled screen on AMD Radeon HD 6320

Reported by: blutigerWilliam Owned by: kallisti5
Priority: normal Milestone: R1/alpha4
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Radeon HD Cc:
Blocked By: #8329 Blocking:
Has a Patch: no Platform: All

Description

After the splash screen of the boot sequence the desktop comes up with a blue, garbled screen. I have to use VESA instead. My system is a Samsung NP305U1A-A02DE with AMD Fusion E-450 and Radeon HD 6320 running hrev43740. Listdev-output attached.

Attachments (6)

listdev.txt (4.1 KB ) - added by blutigerWilliam 8 years ago.
syslog.txt (320.9 KB ) - added by blutigerWilliam 8 years ago.
syslog_neu.txt (156.3 KB ) - added by blutigerWilliam 8 years ago.
syslog_hrev43830.txt (157.2 KB ) - added by blutigerWilliam 8 years ago.
syslog_hrev43835.txt (158.1 KB ) - added by blutigerWilliam 8 years ago.
screenshot1.png (316.8 KB ) - added by blutigerWilliam 7 years ago.

Download all attachments as: .zip

Change History (26)

by blutigerWilliam, 8 years ago

Attachment: listdev.txt added

comment:1 by kallisti5, 8 years ago

Blocked By: 8329 added

Probably also related to #8329

comment:2 by kallisti5, 8 years ago

hrev43767 should resolve this issue so the native resolution should be set properly.

Can you test as soon as you have access to a hrev43767 or higher build?

comment:3 by blutigerWilliam, 8 years ago

Tested hrev43768, but the problem is still there: garbled screen. Attached my syslog.

by blutigerWilliam, 8 years ago

Attachment: syslog.txt added

comment:4 by kallisti5, 8 years ago

try post hrev43810. hrev43810 fixes a *big* oops.

comment:5 by blutigerWilliam, 8 years ago

Thanks for your effort, kallisti. I tested hrev43812, but with no success. The behavior is still the same. :(

comment:6 by kallisti5, 8 years ago

could you re-collect the syslog? Sorry, I know it's a pain... however it's the only way I can figure out what may be going wrong.

Thanks!

by blutigerWilliam, 8 years ago

Attachment: syslog_neu.txt added

comment:7 by kallisti5, 8 years ago

Hmm, it seems encoder_pick_dig is failing.. that a new one.

Likely the cause.. i'll look into it.

comment:8 by blutigerWilliam, 8 years ago

Thanx!

comment:9 by kallisti5, 8 years ago

Actually, I think transmitter_dig_setup is to blame.

I added some needed debugging in hrev43827. As soon as you can, give hrev43827+ a whirl and collect the system logs. This debugging will tell me what table version you have and let to follow the execution path looking for bugs.

by blutigerWilliam, 8 years ago

Attachment: syslog_hrev43830.txt added

comment:10 by blutigerWilliam, 8 years ago

New syslog attached...

comment:11 by kallisti5, 8 years ago

try hrev43833 or later :)

I have a *very* good feeling about that change.

by blutigerWilliam, 8 years ago

Attachment: syslog_hrev43835.txt added

comment:12 by blutigerWilliam, 8 years ago

Sorry, no luck with hrev43835... same problem as before.

comment:13 by chaotic, 7 years ago

Hello blutigerWilliam, hello kalisti5,

i have the same problem with the garbled screen. My system is a Lenovo S205 with a AMD Fusion E-450 and Radeon HD 6320. The native resolution is 1366 x 768 but Haiku can not display. In vesa- mode a resolution of 1024 x 768 is displayed ok.

Can i help somehow ???

chaotic

comment:14 by kallisti5, 7 years ago

The garbled screen is a known issue...I see it on my newer hardware now as well.

I am working to fix it as soon as possible (I have *NO* idea what the fix is yet though)

On the bright side, we are all staring to fail with the same issues vs 100 different issues :)

comment:15 by kallisti5, 7 years ago

...well I do think it's pixelclock related.

Newer cards (HD 5xxx+) see:

  • Analog, video output skewed
  • Digital, black screen

Those make sense for the pixel clock getting out of whack somewhere.

HD 4xxx and before are still reported working. (and all my HD 4xxx and before cards still work)

comment:16 by kallisti5, 7 years ago

hrev43900 should solve this issue.

Please test it and let us know :)

comment:17 by blutigerWilliam, 7 years ago

Yippie Ya Yeah! It works! Thanx, Kallisti! :-)

comment:18 by kallisti5, 7 years ago

Milestone: R1R1/alpha4
Resolution: fixed
Status: newclosed

glad to hear :)

Resolved.

comment:19 by chaotic, 7 years ago

Hello,

my Lenovo IdeaPad S205 is now working fine with radeon_hd driver. Thank you for the very good job, kallisti5.

cheers, chaotic

comment:20 by blutigerWilliam, 7 years ago

Hi Kallisti,

while testing hrev43900 i have spotted some possible bugs.

  1. The resolution 1366x768 is working, but the icons and the deskbar seem to be a little bit stretched. I don't know, if this is a normal widescreen behavior of haiku. I have attached a screenshot.
  1. The only working resolution is 1366x768, every other selected resolution gives me a garbled screen. This would not be a problem, but in cause of this the fullscreen mode of scummvm doesn't work. :-(

Sorry to disturb you again...

Last edited 7 years ago by blutigerWilliam (previous) (diff)

by blutigerWilliam, 7 years ago

Attachment: screenshot1.png added
Note: See TracTickets for help on using tickets.