Opened 8 years ago

Closed 8 years ago

#8367 closed bug (duplicate)

QT apps failing in the latest nightlys

Reported by: SeanCollins Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha3
Keywords: Cc:
Blocked By: #8358 Blocking:
Has a Patch: no Platform: All

Description

QT applications fialing in the latest nightlys, they worked back in the 436xx range, then broke sometime recently. I have not bisected the issue any further then that.

debug with bt

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 1570 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/common/lib/libqupzilla.so.1.1.8...done.
Loaded symbols for /boot/common/lib/libqupzilla.so.1.1.8
Reading symbols from /boot/common/lib/libQtWebKit.so.4.7.1...done.
Loaded symbols for /boot/common/lib/libQtWebKit.so.4.7.1
Reading symbols from /boot/common/lib/libQtScript.so.4.8.0...done.
Loaded symbols for /boot/common/lib/libQtScript.so.4.8.0
Reading symbols from /boot/common/lib/libQtSql.so.4.8.0...done.
Loaded symbols for /boot/common/lib/libQtSql.so.4.8.0
Reading symbols from /boot/common/lib/libQtGui.so.4.8.0...done.
Loaded symbols for /boot/common/lib/libQtGui.so.4.8.0
Reading symbols from /boot/system/lib/gcc4/libtracker.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtracker.so
Reading symbols from /boot/common/lib/libQtNetwork.so.4.8.0...done.
Loaded symbols for /boot/common/lib/libQtNetwork.so.4.8.0
Reading symbols from /boot/system/lib/gcc4/libnetwork.so...done.
Loaded symbols for /boot/system/lib/gcc4/libnetwork.so
Reading symbols from /boot/common/lib/libQtCore.so.4.8.0...done.
Loaded symbols for /boot/common/lib/libQtCore.so.4.8.0
Reading symbols from /boot/system/lib/gcc4/libroot.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot.so
Reading symbols from /boot/system/lib/gcc4/libstdc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libstdc++.so
Reading symbols from /boot/common/lib/libphonon.so.4.4.0...done.
Loaded symbols for /boot/common/lib/libphonon.so.4.4.0
Reading symbols from /boot/system/lib/gcc4/libbe.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbe.so
Reading symbols from /boot/system/lib/gcc4/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/gcc4/libpng.so.1.4
Reading symbols from /boot/system/lib/gcc4/libz.so.1...done.
Loaded symbols for /boot/system/lib/gcc4/libz.so.1
Reading symbols from /boot/system/lib/gcc4/libfreetype.so...done.
Loaded symbols for /boot/system/lib/gcc4/libfreetype.so
Reading symbols from /boot/system/lib/gcc4/libtranslation.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtranslation.so
Reading symbols from /boot/system/lib/gcc4/liblocale.so...done.
Loaded symbols for /boot/system/lib/gcc4/liblocale.so
Reading symbols from /boot/system/lib/gcc4/libsupc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libsupc++.so
Reading symbols from /boot/system/lib/gcc4/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtextencoding.so
Reading symbols from /boot/system/lib/gcc4/libicudata.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicudata.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicui18n.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicui18n.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicuio.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicuio.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicule.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicule.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libiculx.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libiculx.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicutu.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicutu.so.48.1.1
Reading symbols from /boot/system/lib/gcc4/libicuuc.so.48.1.1...done.
Loaded symbols for /boot/system/lib/gcc4/libicuuc.so.48.1.1
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/qupzilla/qupzilla (1570) thread qupzilla (1570)]
0x02bb9802 in _GLOBAL__sub_I_ControlLook.cpp ()
   from /boot/system/lib/gcc4/libbe.so
(gdb) bt
#0  0x02bb9802 in _GLOBAL__sub_I_ControlLook.cpp ()
   from /boot/system/lib/gcc4/libbe.so
#1  0x02ca16f7 in __do_global_ctors_aux () from /boot/system/lib/gcc4/libbe.so
#2  0x02b667d5 in _init () from /boot/system/lib/gcc4/libbe.so
#3  0x00100910 in init_dependencies () from /boot/system/runtime_loader
#4  0x00100d3c in load_program () from /boot/system/runtime_loader
#5  0x001061f2 in runtime_loader () from /boot/system/runtime_loader
#6  0x7ffeefec in ?? ()
(gdb) 

from syslog

KERN: write access attempted on write-protected area 0x37f3 at 0x023d5000
KERN: vm_page_fault: vm_soft_fault returned error 'Permission denied' on fault at 0x23d5160, ip 0x2bb9802, write 1, user 1, thread 0x3e5
KERN: vm_page_fault: thread "qupzilla" (997) in team "qupzilla" (997) tried to write address 0x23d5160, ip 0x2bb9802 ("libbe.so_seg0ro" +0x108802)
KERN: debug_server: Thread 997 entered the debugger: Segment violation
KERN: stack trace, current PC 0x2bb9802  _GLOBAL__sub_I_ControlLook.cpp + 0x15:
KERN:   (0x7ffeeef0)  0x2ca16f7  __do_global_ctors_aux + 0x27 (closest symbol)
KERN:   (0x7ffeef00)  0x2b667d5  (/boot/system/lib/gcc4/libbe.so + 0x15)
KERN:   (0x7ffeef0c)  0x100910  init_dependencies__FP7image_tb + 0x7c
KERN:   (0x7ffeef4c)  0x100d3c  load_program + 0xc8
KERN:   (0x7ffeefac)  0x1061f2  runtime_loader + 0xfa

Change History (2)

comment:1 by SeanCollins, 8 years ago

rev 43809 gcc2h, finished testing , 43762 is the very last revision QT works on.

Last edited 8 years ago by SeanCollins (previous) (diff)

comment:2 by anevilyak, 8 years ago

Blocked By: 8358 added
Resolution: duplicate
Status: newclosed

Duplicate of #8358. That having been said, in general Qt will break on occasion regardless, since it's built with gcc4, which we don't currently guarantee binary compatibility for.

Note: See TracTickets for help on using tickets.