Opened 7 years ago

Closed 7 years ago

#8396 closed bug (fixed)

Building hrev43866 in Haiku fails (at least since hrev43849)

Reported by: taos Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/Development
Keywords: Cc: korli
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using hrev43865 (gcc2h) from Haiku Files.

Building hrev43866 fails with:

...failed Link /GIT/haiku/generated/objects/haiku_host/x86/release/tools/copyattr ...

Complete terminal output is attached.

Attachments (2)

Terminal_output.txt (8.2 KB) - added by taos 7 years ago.
Terminal output: Build failure in hrev43865.
syslog.old (512.0 KB) - added by SeanCollins 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 7 years ago by taos

Attachment: Terminal_output.txt added

Terminal output: Build failure in hrev43865.

comment:1 Changed 7 years ago by bonefish

Component: Build SystemFile Systems/BFS
Owner: changed from bonefish to axeld

The only reason I can think of why opening a file would fail with B_BAD_DATA is a FS corruption. Please check your syslog -- BFS usually logs those kinds of errors.

comment:2 Changed 7 years ago by taos

It is FS corruption - checkfs finds b+tree errors on my SDHC cards mounted as /GIT. So, this ticket could be invalid.

But the strange thing is: Card 1 with hrev43866 shows b+tree errors, after initializing and formating as BFS the SD card no longer shows errors, however, after downloading the latest revision and trying to build a gcc2 hybrid image checkfs finds b+tree errors again. Card 2 (with hrev437xx source code) shows no errors, after updating the source and trying to build haiku there are b+tree errors, too. I'm going to order a couple of new SD cards to see if the same happens again.

comment:3 Changed 7 years ago by SeanCollins

renaming the objects folder in my generated fold solved the problem for me, but its a bandaid solution.I also suffer the same problem, just for ticket validation.I will attach my log. Yes it appears to be a bfs corruption issue.

related to ticket #8392

Last edited 7 years ago by SeanCollins (previous) (diff)

Changed 7 years ago by SeanCollins

Attachment: syslog.old added

comment:4 Changed 7 years ago by taos

I've got rid of b+tree errors, but now building hrev43874 gcc2hybrid fails with:

.
.
.
BuildAlternativeGCCArchive1 /GIT/haiku/generated-gcc4/alternative_system_libs.zip 
Preparing contents of archive /GIT/haiku/generated-gcc4/alternative_system_libs.zip ...
Error: Couldn't access "/GIT/haiku/generated-gcc4/build_packages/freetype-2.4.6-x86-gcc4-2012-03-15/common/lib/libfreetype.so.6.7.1": No such file or directory

/GIT/haiku/build/scripts/build_archive /GIT/haiku/generated-gcc4/alternative_system_libs.zip /GIT/haiku/generated-gcc4/haiku-alternative-gcc-init-vars /GIT/haiku/generated-gcc4/haiku-alternative-gcc-make-dirs /GIT/haiku/generated-gcc4/haiku-alternative-gcc-copy-files

...failed BuildAlternativeGCCArchive1 /GIT/haiku/generated-gcc4/alternative_system_libs.zip ...

BUILD FAILURE:
...failed updating 1 target(s)...
...updated 2906 target(s)...

cd /GIT/haiku/generated-gcc4
export HAIKU_IGNORE_USER_BUILD_CONFIG=1
export HAIKU_ADD_OPTIONAL_PACKAGES=Pe/Nano/Vision/P7zip/XZ-Utils/Development/Git/OpenSSH/OpenSSL/MandatoryPackages/ICU/DevelopmentBase/CDRecord/LibIconv/DevelopmentMin/Yasm/Perl/Expat/Curl/CARootCertificates/PCRE/Tar/Bzip/Ctags/Sed
export HAIKU_PRIMARY_GCC=2


jam -q  haiku-alternative-gcc-archive ;

...failed InvokeSubJam1 /GIT/haiku/generated-gcc4/alternative_system_libs.zip ...

comment:5 Changed 7 years ago by SeanCollins

I'm in the same boat now myself. This issue seems to crop up after compiling a few times, which means this is likely related to the issues in 8392 and one of the known bfs block cahce issues. It really only seems to crop up under heavy,heavy disk write demand.More number of files, rather then size. At least thats my observation from experimenting.

Its really easy to reproduce to, just run a bunch of jam -a builds even on a clean install with a few threads, and it pops up right away.Takes me between 3-5 trys and or fresh code pulls from git with jam -a is about all it seems to take.

comment:6 in reply to:  4 Changed 7 years ago by anevilyak

Cc: korli added

Replying to taos:

I've got rid of b+tree errors, but now building hrev43874 gcc2hybrid fails with:

<snip>

This part is due to the recent changes to make freetype an external package. Adding Jérôme to CC.

comment:7 in reply to:  4 Changed 7 years ago by diver

Replying to taos:

unzip -d ~/haiku/haiku/generated.x86gcc4/build_packages/freetype-2.4.6-x86-gcc4-2012-03-15 ~/haiku/haiku/generated.x86gcc4/download/freetype-2.4.6-x86-gcc4-2012-03-15.zip

should fix it.

comment:8 Changed 7 years ago by taos

Unzipping freetype-....zip does indeed solve the problem with the freetype package. Unfortunately, I'm now back to build failure because of b+tree errors.

comment:9 Changed 7 years ago by mmadia

Can you retest with hrev43930 or newer? This may require running checkfs on the affected partitions.

comment:10 Changed 7 years ago by taos

I did retest with hrev43925 yesterday - running checkfs fixed the b+tree errors, however, I visited KDL during building and got b+tree errors again (fixing these took a few hours and at least 20 reboots because checkfs crashed on me repeatedly - supposedly due to #8438 or #8437). Unfortunately, I won't be home for the rest of the week, so I can't use my usual build machine (old centrino laptop). The atheros wifi of my netbook doesn't work with the new router here (it did before the router was replaced a few months ago), so without a proper network connection I can't really build a new haiku revision. I'll retest on Saturday with a current nightly and my standard build machine.

Last edited 7 years ago by taos (previous) (diff)

comment:11 Changed 7 years ago by taos

So far, I haven't seen any b+tree errors again. Thanks!

comment:12 Changed 7 years ago by diver

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.