Opened 8 years ago

Closed 8 years ago

#8424 closed bug (duplicate)

Plugin ffmpeg crashes

Reported by: joy Owned by: nobody
Priority: normal Milestone: R1
Component: Audio & Video/Codecs Version: R1/Development
Keywords: ffmpeg Cc:
Blocked By: #8393 Blocking:
Has a Patch: no Platform: x86

Description

File with bug: /boot/system/add-ons/media/plugins/ffmpeg

MediaPlayer crashes when i try to start a mp4 movie with the following message:

Reading symbols from /boot/system/lib/libnetwork.so...done. Loaded symbols for /boot/system/lib/libnetwork.so [tcsetpgrp failed in terminal_inferior: Invalid Argument] [Switching to team /boot/system/apps/MediaPlayer (694) thread frame generator (710)] 0x026001e6 in put_h264_qpel16_mc32_mmx2 ()

from /boot/system/add-ons/media/plugins/ffmpeg

(gdb)

*Terminal says this* Compiler did not align stack variables. Libavcodec has been miscompiled

Was working in Nightly build 43873(File date 17 mars), but broken in 43877(File date 18 mars) and still broken in 43893.

See attachments for full error logs from Debug and terminal.

Attachments (3)

FFMPEG_Full_Debug_log (3.0 KB ) - added by joy 8 years ago.
FFMPEG_no_error (1.4 KB ) - added by joy 8 years ago.
FFMPEG_Error_in_terminal (1.6 KB ) - added by joy 8 years ago.

Download all attachments as: .zip

Change History (6)

by joy, 8 years ago

Attachment: FFMPEG_Full_Debug_log added

by joy, 8 years ago

Attachment: FFMPEG_no_error added

comment:1 by joy, 8 years ago

Has a Patch: set

by joy, 8 years ago

Attachment: FFMPEG_Error_in_terminal added

comment:2 by joy, 8 years ago

Has a Patch: unset

comment:3 by luroh, 8 years ago

Blocked By: 8393 added
Resolution: duplicate
Status: newclosed

This and other recent problems with ffmpeg are being tracked in #8393.

Note: See TracTickets for help on using tickets.